0

So, I was trying to root my Samsung Galaxy J7 Prime. This was the first time I tried rooting anything. I ticked OEM, downloaded Odin and TWRP following the guide on https://odindownload.com/root-android/. Anyways, I did everything until Step 7, and my phone reset automatically but by mistakenly I priced start again before the phone could reset so idk what happened between there and as soon as my phone reset I panicked thought I fucked up and I removed the cable connecting my phone to my laptop(Yes, I am an idiot, I know) and now my phone won't boot and is stuck on "Samsung Galaxy J7 Prime, powered by android screem". I tried going into recovery or the download mode again but I can't. It won't do anything and the phone won't turn off either. When I press power+home+volume up, nothing happens, when I press power+home+volume down for fastboot, the phone restarts but only to get stuck at the boot screen again. It won't advance. Please help. What should I do now?

P.S, I think I also forgot to tick USB debugging from developers mode.

  • don't worry. you may lose your data, but phone is nearly unbrickable. Just flash stock ROM from download mode. if you can't enter download mode buy JIG dongle amazon.com/gp/aw/d/B07QWTNHL3 – alecxs Nov 9 '19 at 10:16
  • try again Power + Home + Volume down when device is powered off. Here you can find ROM and instructions fw.updato.com – alecxs Nov 9 '19 at 10:41
  • but first, try to enter recovery mode again and again. once in TWRP install this zip forum.xda-developers.com/android/software/… maybe that's all you need to fix your phone – alecxs Nov 9 '19 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.