I'm having my first major issue with my phone, the Atrix (not Atrix 2). The phone is stock Gingerbread, not rooted, and I don't download any dubious or non-Market apps. While using my phone today it suddenly rebooted. Upon reaching the unlock screen, neither the screen nor the buttons would respond to any kind of input, nor have they since. I can't even turn on the screen by pressing the power button; I have to plug it in to the charger. The only way to try to restart is to pull the battery. It seems to me that the problem is with the unlock screen, which I think belongs to the launcher app. The menu bar at the top of the screen seems to indicate that other systems are functioning properly -- the clock in the corner stays up to date, while the lock screen's clock doesn't change after booting. The icons at the top indicate that bluetooth and wifi are active and the strength of the wifi signal varies when I move around.

Let's see, what else -- I wasn't doing anything unusual with the phone when it rebooted. It has suddenly rebooted a couple times in the past couple days before this, but had no noticeable problems once it started back up.

Can anybody suggest what I should try next? I'd like to avoid having to wipe it clean if possible. I have managed to get into the boot options by holding the volume key and pressing the power button, and try to boot into recovery mode from there, but that just hung. I have the android sdk with adb installed on my linux laptop, so i can try connecting the debugger in the morning, but i'm not sure what to try when I do.

Sorry if this is an incoherent jumble -- I'm tired and I'm going to bed.


I connected the phone to my computer and looked at the logs in LogCat (I've done a little bit of Android development). I'm not seeing any obvious signs of what the problem is. Admittedly, I have no idea what to look for. The closest I can get is this INFO message when I try to unclock the screen when it's active:

04-15 16:34:39.719: INFO/InputDispatcher(1652): Application is not responding: Window{40a2fb20 Keyguard paused=false}. 11148.9ms since event, 5009.5ms since wait started

and this is all that happens when I press the power but to try to turn the screen on:

04-15 16:38:00.369: DEBUG/KeyguardViewMediator(1652): wakeWhenReadyLocked(26)

There are no error stack traces being logged for either event. Ideas???


It appears to be the Home app. See details in the comment below. Can I use ADB or another tool to remove and reinstall the Home app? I know that with my own apps, I can just use adb install and adb uninstall, but I don't know if it's that simple with other apps, or where I would get a clean copy of it from.


I tried everything there was to try, including writing an app to programmatically wake up and attempt to unlock the screen, which worked on my tablet but not the phone, so I could try to salvage some data. I finally had to just do a hard reset on the phone, and that worked, so for now the phone is working again.

  • Personally, I had pretty much the exact same thing happen to a Droid X. Phone would boot, but it was impossible to unlock the phone. I wiped the phone to no avail, took it back to Verizon, they re-flashed it, but ultimately it was decided that it was some sort of hardware fault, and I was given a replacement.
    – Brandorf
    Apr 16, 2012 at 17:12
  • Strange. The error makes it sound like you might be saved by a factory reset, but otherwise I would suspect the touchscreen has failed. Apr 16, 2012 at 20:33
  • 2
    It's not a touchscreen failure. The first debugging message I listed there is happening in response to touching the screen. I have now confirmed my initial thought that it's just the home application -- I received a call and was able to unlock the screen to answer it. Once I answered it, I got a popup saying the Home application was not responding and forced closed it. During the call I could use the features specific to the call, but couldn't use the home button or the power button, as before. So I would like to remove and reinstall or repair the Home app over ADB. Is this possible? Apr 17, 2012 at 2:15

3 Answers 3


i had the same issue with screen not coming to live after proximity sensor has turned it off once. I tried to boot in safe-mode and the phone is working perfectly and there is no such issue in safemode. I know this is not permanent solution (there must be some limitations of safemode, though i have no idea about them), but it atleast points us that this is not hardware problem and some application is messing up with the proximity sensor.


As you have said yourself, you could install/uninstall through ADB.

My advice would be to install a alternate Home screen app through adb and restart the device. (Installing an alternate home app would clear the previous home app's defaults).

When the Home Application is about to be started, it would show you the option to choose one of the Home apps from the list. Simply select the alternate one.

You would need an Home app's APK for this, which you will have to download on your PC. Just get any alternate Home app APK, install it, boot into your device. Launch Google Play and install another Home App and uninstall the one which you installed through adb.

You could uninstall the stock Home app (I am assuming, your are on stock) easily, since you are rooted via Root Explorer or any similar app.

If you don't want to install an app downloaded through internet, simply create an launcher app yourselves.

Here is the android's sample home app.

Android Developers - Home Sample

or get source code for launchers like ADW Launcher here-

ADW-Launcher-Android Google Code

In all this, I am assuming you have USB debugging enabled on your device.

  • Thanks! I'll give this a try when I get home from work today. Apr 18, 2012 at 16:13
  • No luck - I installed an external home app, and it's there, but I never get asked to use it, and still can't get beyond the lock screen. Maybe this question would be appropriate to take over to StackOverflow. Apr 19, 2012 at 2:20
  • Hmm.. give this app a try, install via browser, and re-boot. MotoBlur Homr Google Play or try force starting the alternate home app via adb as shown here - Start app via adb - stack overflow Apr 19, 2012 at 3:17
  • MotoBlur home won't help, because it just allows you to choose the regular home screen when an alternate has been installed. But I have managed to install Go Launcher Ex, and start it via adb using those instructions and this package/Activity name combo: com.gau.go.launcherex/com.jiubang.ggheart.apps.desks.diy.GoLauncher. It starts up, but does not affect the locked state of the screen. I think I'm going to have to try to write a simple app that attempts to unlock the screen and run that from adb. Apr 19, 2012 at 5:30

I have read at xda that you could boot your Atrix in safe mode and only load essential system files. From there you can delete the defective home app or replace it with an other home app.

To do this, power off your Atrix, and press the power button to turn it on. Once the boot ANIMATION starts, immediately press and HOLD the vol up + vol down buttons until you get a long vibe, then release. you'll then see 'safe mode' at the lower left of the screen when the lockscreen comes up. (from xda-developers)

Here is the XDA thread about Atrix in safe mode

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .