2

I own an LG-K430T, and I use it to share internet with my Desktop PC through USB tethering. Or I did it for a year straight until today, when my PC isn't recognizing my phone anymore, neither on Windows 7 nor Ubuntu 18.04.2. It doesn't even allow to share files, since there isn't a pop-up(neither in the phone nor the PC), but the phone does charge. I thought it could be my USB cable that worn off, but using this same USB cable with my sister's Huawei, it does allow to share files/internet. Furthermore, I tried with 3 different USB cables and different ports, and my phone still isn't recognized. Then, I tried it on Ubuntu, and to my surprise, it's still not recognized. So, I think it's safe to say the cable isn't the issue, nor the operative system( Also, I restarted both the phone and the PC) Then , In ubuntu, I tried to enable USB debugging followed by lsusb and nothing yet. My phone was last updated in april 2019 and its android version is 6.0, so I don't have a clue about what's causing the issue, although I'd blame the phone..

On windows,I have tried to update drivers of the 'Unknown device' on Device administration, but it says they are already up-to date

EDIT: Answers to comments: lsusb output:

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 1004:6344 LG Electronics, Inc. G2 Android Phone [tethering mode]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f9:0413 Brother Industries, Ltd 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 04f3:0235 Elan Microelectronics Corp. 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

(THE LG PHONE THAT IS TETHERING IS ANOTHER ONE, DIFFERENT FROM THE ONE WITH THE PROBLEM). So, in short, lsusb doesn't recognize it. The MTP option looks already enabled

Further info

The other day a guy enabled USB debugging on my phone and got his computer to read its files!(He had a version of Windows). When I got home it worked too in my Windows! Then it downloaded some drivers and asked to reboot, which I did. After the reboot, I tried tethering and didn't work(The option to turn on was there, but when turned on, nothing happened). I thought it was because of the USB debugging and disabled developer options completely. Unfortunately, my PC stopped recognizing my phone. I said, "well, at least I can now share files..." but, surprisingly,when I turned USB-debugging back on nothing happened. Now, there is a difference which I observed between his way of activating USB-debug vs my way. It is that in his way the USB-debugging is shown active both on Settings AND in the Notification Panel(in a permanent way, i.e. it doesn't go if I press "clear all" notifications), while when I activate it,no message is shown in the notification Panel. He must have done it differently to give it more priority or something...

  • What is the output of lsusb. See this for help android.stackexchange.com/q/144966/131553 – beeshyams Nov 13 '19 at 7:04
  • 1
    If your phone is not visible via lsusb it may have a damaged USB port (e.g. loose connection). – Robert Nov 13 '19 at 8:43
  • when connected, in developer options scroll down to usb configuration and select MTP – alecxs Nov 13 '19 at 14:48
  • Just in case it's missing, download and install OEM USB Driver for Windows from the official LG site. – Andrew T. Nov 27 '19 at 2:33
  • @AndrewT. Unfortunately there's nothing for my model there. – Diego Nov 27 '19 at 2:48
0

This is one of those things that can be tricky to fix I think, because there are multiple points of failure (getting 2 different hardware devices to communicate over USB through 2 further operating system layers). But as AndrewT mentioned, my guess would be the drivers.

If I remember correctly I've had several episodes before of playing musical drivers + USB cables. I'm pretty sure what ended up happening most often was I'd finally get a successful connection upon switching cables (after focusing on reinstalling drivers over & over for a few hours). I also recall one time, the solution was switching from the USB 3.0 port I was using to a 2.0 port which fixed it instantly after hours of madness trying various drivers and cables.

You said you've tried a few of each of those though. One thing to keep in mind is it can be surprising just how picky your phone can be in terms of the cable you use. A couple times I've tried at least 4 or 5 different (microUSB) cables, switching back and forth and alternating with yet another driver install only for it to keep failing. Then when I eventually desperately dug a spare cable out from the couch cushion or something, it suddenly worked like a charm. I confirmed it on those occasions too by going back to each of the previous cables once I was 100% sure everything was indeed working, and sure enough, they all refused to work; only the weird, thin, chinese crap cable from who knows where seemed to do the trick. Android can be extremely picky, that's sort of the gist of what I've seen anyway.

Your "Further Info" makes me believe even more that it's probably your drivers though, if you know for sure that the connection stopped working following a driver update, and knowing that it DID work prior to that. The final thing I can offer is that I've ran a few LG phones over the years too, and I think they're particularly bad with fragmenting the driver situation with their own driver packages & LG-branded "Control Center" or "USB Tool"-type apps. While the android Universal Drivers have generally worked for most of my phones most of the time, I want to say you should try looking for any & all alternative drivers out there, especially if you can find some from LG's site specifically - that might be simply the only thing that will work, while all of the other usual "Universal" android software packages out there won't (for whatever reason).

But yeah... keep experimenting, try as many different connections as you can in The Trifecta (drivers, cables, USB ports), borrow some friends' cables or computers if you have to. I bet a single lucky one of them will suddenly work like nothing was ever wrong, and likely for no reason, as frustrating as it is.

0

I had the same issue with my rooted LG G2 D802. I run a heavily modified by me stock KK ROM, Xposed, modified kernel, boot image, busybox, init.d, build.prop, system files, xml, apks, db... and everything you can think of. I like to understand what every single file on my system is and does, and thought I've gone too far and broke things.

Had Developer Options and Debug USB enabled, so at least I could see it tru adb devices and adb pull / push files to and from PC, also adb shell to explore it (for conveniece I use ADB Putty https://github.com/sztupy/adbputty/downloads). USB tethering would definitely not work though.

When in TWRP recovery, phone was recognized no problem in Windows, and I could browse tru sdcard as usual.

I also tried different cables, computers, usb ports, operating systems, drivers, but nothing. Now I'm reasonably sure the issue is to be found in some corrupt data inside the smartphone. I say this because now my device works again in MTP mode and all the other available connection modes.

How did I solved the issue? Unfortunately I don't know exactly.

What I can say is that I was trying to solve an apparently blatant hardware issue, with the screen flickering, freezing to white noise, especially when warm (not even hot), and when fast scrolling. This screen problem happened for the first time about one month ago, the connections issue was more than a year old, so the two are not related.

Disassembled the phone, disconneted and reconnected the screen connector. White noise / freezing problem still there (disabled animations in Developer Options as a work-around to flickering issues).

Entered TWRP recovery, tried the usual stuff Wipe Cache / Wipe Dalvik, noted that /data partition was non mounted as r/w (infact /data/dalvik-cache was non actually deleted), tried Fix Contexts, rebooted. It took a long time, was rebuilding cache or something else, welcomed by the dreadly dialog

UIDs on system are inconsistent
You need to wipe your data partition or your device will be unstable
[I'm feeling lucky]

Ok, at this point found many /data/data folders empty, so I had to open every app interested and reset things to my likings, not a great deal. Fixing the inconsistent UID thing was a bit trickier, had to read into /data/system/UIDerrors.txt to find the culprit app, and changed UID accordingly in respective /data/data folder.

After this my system was stable and MTP connection worked again.

I know it's not what you want to read, but with a backup + factory reset you will restore MTP functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.