1

SO, I have an MT6739 dveice with Android 8.1, it's not A/B seamless, and it is not TREBLE.

I have used a tried and tested method to remove DM-Verity. On this device it was in the DTB, in the boot and also in the vendor partitions. I use Magisk to get me root and I have removed and installed lots of /system/apps, changed the audio, bootanimations etc on the device. I even changed the backgrounds and tweaked the Launcher.

However whenever I come to change anything in /system/build.prop the device bootloops!

I have tried this with Magisk DM-verity ON/OFF with no effect. I also copied back a build.prop from my PC and it worked fine again. So, something must be looking up the build.prop and checking for changes.

All I have done is change the ro.product.model property to be super sure nothing in the build.prop is incorrect. I have tried with setting permissions (644, for some reason they are 600 (RW - - ) on the device so tried that too).

There is a build.prop in the /vendor partition. i have heard of this checking the fingerprint of the system/build.prop, but they are different anyway on the stock ROM.

I also tried just copying the build.prop from /system into here so they were identical.

Fresh out of ideas!!

Does anyone know what is going on here. I can literally change anything I want on the device as normal/pre-verity days except for the build.prop settings.

  • maybe you have CRLF instead of LF line ending (check with Notepad++) – alecxs Nov 13 '19 at 14:27
  • As @alecxs mentioned CRLF could be a reason. Do dos2unix on build.prop. Also check SELinux label. Check kernel log and logcat for any hints to the reason of bootloop. – Irfan Latif Nov 13 '19 at 15:02
  • TY for the comments. I will try that, I have been out all day today so will try it tmw. Problem is, I am literally only changing the device name or model so I dont create a line feed or CR at all. I am on a W10 system though so it is a little bit notorious for that. Other clue is that if I edit the build.prop back to the way it was and then copy it to the device, it boots fine!! – Techster35 Nov 14 '19 at 15:25
  • One thing I am really poor with is getting logs from a device. Is there a decent thread anywhere that can help me set up Logcat on the device? – Techster35 Nov 14 '19 at 15:27
  • OK, so logcat learned, here's an update. I copied the build.prop, made 1 change to the device name, making sure to not make any line breaks etc. I ran the build.prop through DOS2UNIX. I replaced it on the device, chmodded it, made sure magisk was running and had verity checking off and restarted the device with logcat running in my ADB window. Still bootlooped. No logcat log a6t all, "still waiting for device". – Techster35 Nov 18 '19 at 13:32
0

See when you did the DM Verity patch, have you patched the boot.img to support Android 8.1? if working on Win can use ClassyKitchen. If working on Linux, AIK Linux is the way to go. i'd suggest using classykitchen and patch for DM verity and enable 8.1 support. worked for me. running 8.0 Oreo. ;)

  • Hi Aleks, No I didn't patch the boot.img specifically to support Android 8.1. Would you expand a bit on that. In this device to remove DM-Verity you need to find the fstab files in vendor (easy) and also the boot DTB, (not so easy on Win10 because you cannot get write access into the RAMDISK from 7.zip). I have uised Magisk successfully to do this however, but even running Magisk the issue is present. – Techster35 Jan 9 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.