2

About phone: Huawei P9 lite VNS-L21C432B161 (central Europe)

First modifications A long time ago i unlocked bootloader and successfully rooted the phone. I turned off OEM unlock option in settings after rooting, because someone said i should do so for security. Then came EMUI 5 OTA. It somehow updated itself without me agreeing. Android nougat detected, that the bootloader was unlocked and so it assumed that OEM unlock option was also ENABLED when it really wasn't, making me unable to re-enable the option. So i used the https://forum.xda-developers.com/huawei-p9lite/how-to/tutorial-rollback-n-to-mm-c432-devices-t3563955432-devices-t3563955" <-- official rollback package and installed stock ROM through dload.

Here is the part where i messed up horribly Now i wanted to update to android 7 again, but updater wasn't giving it to me and i was unable to flash it through TWRP. I installed the rollback package again through download mode as it said it allows any ROM to be installed, hoping i could then install android 7 through Download mode, which would in turn allowed me to install newer version of TWRP to then install a nougat based custom ROM.

Huawei's Erecovery and download mode

Erecovery: Accessed by pressing volume up during boot for 3 seconds, is supposed to download a working ROM for your phone, is saved in different place than recovery

Downlaod mode By placing a folder with name 'dload' with supported OS on sd card in a form of UPDATE.APP, download mode installs this version, relocks bootloader and rewrites recovery with a normal one. (Relocking bootloader with custom recovery probably broke it, still doesn't explain why i can't access fastboot or download mode itself at all.)

Now i am stuck at the 'Your device has been unlocked and can't be trusted. Can't access bootloader, phone doesn't seem to be detecting the Power+Volume down combination < not the case in duplicate post. Recovery doesn't boot at all, it just goes straight to the normal boot dialog

Result of attempting to boot into system, erecovery or recovery

Using the Power + VolumeUp + Volume Down combination to enter the download mode yields a slightly different warning but still gets stuck at it as well.

enter image description here

I think that the only way to fix it may be to dead flash it with stock ROM. I found a program (IDT) for this but it requires a "image xml file" and i don't know where to find it. Goal: to get to bootloader without using volume keys( it just doesnt work for some reason) and without entering system/recovery/erecovery as these broke as well.

Thanks in advance

  • 1
    Possible duplicate of How to enter in TWRP/recover on Huawei P9 lite with keys? – alecxs Nov 13 '19 at 17:16
  • please descripe "gets stuck" a little more, maybe there is hope. did you try adb connection while in "stucked" twrp? and whats different between download mode and bootloader mode? (i don't own Huawei) pictures would be helpful – alecxs Nov 13 '19 at 22:06
  • 1
    @alecxs Edited the question to explain – miso2271 Nov 14 '19 at 21:30
  • good luck and don't flash stock ROM completely i am afraid this may re-lock bootloader, and then you're screwed – alecxs Nov 14 '19 at 22:55
1

Nevermind i fixed it. I could access bootloader by pressing on volume down REALLY HARD. For whatever reason, light press and hold was enough for download mode but not enough for bootloader. Now i should be able to flash all the parts individually after extracting the UPDATE.APP. Thanks for help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.