2

In short, my phone cannot connect to the internet via 2 WiFi access points in my house. 4G mobile data works fine. Connecting to other WiFi and hot-spots away from my own WAN works fine.

All other devices, around 14 which includes phones, laptops, PC's, servers, VM's and 2 chromecast devices, all work without any issues.

My mobile phone worked fine until sometime late Friday afternoon. I did not install any new software or fiddled with the settings in days. Phone works well no issues with anything.

Mobile Phone - Doogee N10 - about 1 year old on Android 8.1.0

Router WiFi AP 1 - TP-Link Archer VR1600v IP 192.168.1.1 WAN connection

WiFi AP 2 - Netgear R6020 IP 192.168.1.178 (reserved)

LAN to LAN connection between the TP-Link and the Netgear Routers.

Netgear Router WAN port is disabled.

DHCP runs on the TP-Link Router LAN IP Range via DHCP 192.168.1.100 - 192.168.1.200 /24

Test 1 : 4G mobile data enabled / WiFi disabled - internet access OK from all apps.

Test 2 : Switch WiFi on for AP 1 (TP-Link) - establish link, gets IP does not report internet access problem. - But all apps don't connect to internet, browser times out.

Test 3 : Switch WiFi on for AP 2 (Netgear) - Result same as test 2 - No internet connection.

Test 4 : Get another member of the household to switch on WiFi hotspot on their mobile phone - Connects and internet works fine on all browsers and apps.

Things I have done to check out possible issues:

  1. Assigned a reserved IP of 192.168.1.177 on the DHCP in case of aduplicate IP from another device.

  2. Checked firewalls and black lists and filters on both routers, nothing. I can see the connected Doogee mobile phone in the WiFi connected listings same as all other devices.

  3. Rebooted, powered down and deleted all the WiFi networks settings one by one made no difference.

  4. On the Doogee Android admin menus, there is an option to completely reset all the networking configuration settings to factory. Done, re-entered all the settings and made no difference.

On my PC (Linux), I have 2 terminal sessions open. On the 1st one I ping a random ftp site somewhere on another continent. Ping is stable at about 500ms. This is my confirmation that there are no issues with the WAN connection. On the seconds terminal, I ping the Doogee Mobile phone on the 192.168.1.177 IP.

  1. Phone connected to AP 1, it often stops randomly with no ping activity, and then just carries on normally after some time.

  2. Phone connected to AP 2 pings seems better without long ping pauses.

  3. Switching between AP 1 and AP 2:

    3.1 AP 1 - When switching to AP, it can take up to a minute before the ping responds.

    3.2 AP 2 - Ping resumes as soon as a connection to AP 2 is established.

  4. Pinging the Doogee is all over the place. Ping times vary anywhere from 2ms to around 700ms.

I don't have any side loaded apps installed. Everything is from Google Play. I installed Trend Micro mobile AV briefly just to make sure it is not something that the Play store didn't pickup.

I can from the browser on my phone connect to any other server / router on my LAN. I can connect to both the routers management interfaces. I can use my "Fing" app to browse all the devices on the network, port scan them and ping them from my phone. Fing however sometimes reports that I do not have internet access, but not all the time.

It seems like my phone refuses to connect to the internet via my WAN port. All other devices have no issues via the same WAN port. My phone connects to the internet via all other means except the WAN port on my network. No firewall or blacklist preventing it. No duplicate IP's.

I am completely baffled, any ideas or pointer welcome please :)

3
  • Installed various tools to analyze the the network and DNS changers. The DNS changers tries to establish some sort of a VPN but none makes an difference to the connection status via WiFi. I did pick up that the network analyzers all report my WiFi DNS as 192.168.1.1 (my gateway IP) and 0.0.0.0??? I don't think that is right? I tried twice now to reset all network setting, but this does not change or reset the DNS. Last thing I want to do is a factory setup.... So the DNS does not come from the router either, which points to my ISP's default DNS. Now how do I fix the DNS or reset it? – Oscar Nov 17 '19 at 7:55
  • So by editing the advanced setting of each WiFi connection and changing it from DHCP to Static, I can set my static IP the same as the reserved IP of 192.168.1.177 and the the DNS to anything I like. So I tried 8.8.8.8 and 1.1.1.1 and my local ISP's DNS setting, all with the same new outcome. When I use the static settings, the problem reverse. I can now see the interwebs, but my local LAN via WiFi is missing.... I can now browse and ping and traceroute and port scan any website, but the local LAN including my 2 chromecast devices are missing. – Oscar Nov 17 '19 at 9:37
  • Fing tells me that I don't have a WiFi connection, but I have, minus my local LAN. The IP Tools app now tells me that the DNS is what I set it and not 192.168.1.1. Aaaargh!!! – Oscar Nov 17 '19 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.