1

I translated the firmware Flyme 8.0.0.0A Stable (RU & UA) for Meizu Note 9 and Meizu 8X, but I can’t kill the Chinese in the quick settings: enter image description hereThe fact is that China’s events are taking place there - the usual date, for example, if you translate from Chinese “己亥 年 十月 廿六” - “October 26.” Who can help remove this problem from the quick settings? Or at least tell me where to look in SystemUI.apk, I suspect that somewhere in the smali code. Thanks.

2
  • That setting depends on the locale. If you simply translated parts of the UI but didn't setup a proper locale it will keep the Chinese text for data. I'm also using the Chinese ROM and an app to add the intended locale and the date shows up in the locale's language.
    – user276392
    Nov 25 '19 at 14:26
  • Thanks, but of course I apply localization through morlocal2, because I add to SystemUI.apk folders: "/res/values_ru" and "/res/values_uk", files in folder "/res/values" I do not change. English is the default lang. The hieroglyphs that are shown in the screenshot do not change due to a change in localization, it is written in the smal code itself, or there it is registered for parsing this from a Chinese site, there are some dates that are not current yet.
    – boinare
    Nov 25 '19 at 19:09
1

I think that you are doing the similar stuff as I do. I have Meizu 16Xs (Same CPU as Note 9) and I'm trying to mod actually the: Flyme 8.20.1.7 beta (chinese firmware)- which is by the way IMHO more stable, at least for my device, than 8.0.0.0A. What I found out, is, that you can in some way partially "convert" the "Chinese" version of firmware to the "Global" by changing the single parameter in /system/build.prop file.

This is the original setting: ro.product.locale=zh-CN

Try to change it to: ro.product.locale=en-US

After restarting your device, this will give you "Global look", which means:

  • In the quick settings on the top-right, there won't be "notification setting" icon anymore, but will be changed to "cog-wheel" -> which means it's link to the "Settings"
  • In top left (where you are now seeing the chinese characters), you will see network carrier info and current date
  • You will be able to change the "Region" from the Settings->Language and Time
  • This also unfortunatelly will disable some options of the chinese rom, which means:
    • no Dark(night) mode (doesn't work even if found by app "quickshortcut maker" and tried to turn it on)
    • No advanced notification settings available (you won't be able to set priority of notifications anymore)
    • no Driving mode
    • Aicy link will dissappear from the settings menu (this I don't know why, will stay dissappeared also after changing the setting back to the "zh-CN", and will remain like this until you do the "factory reset", but other mentioned stuff will return back after changing to "zh-CN"...)
    • Digital health link won't work
    • chinese theme app won't work (can be partially solved by using the CustomizeCenter.apk from the Global firmware, but there will be only wallpapers loaded then, no themes) as I found out, that theme app's functionality relies on the setting "zh-CN" or "en-US".
    • you won't be able to change the lock screen wallpaper by swiping to the right on the lockscreen anymore
    • And I think there are also some other things but I won't be listing everything

For the above mentioned reasons I'm rather staying with the option "zh-CN" (as I would like to use these options, which are disabled in the "Global" rom) and I'm trying to ignore the above mentioned chinese characters in the quick settings.

But what I can tell you (hopefully might help), I found out what these characters actually probably are: It's probably the chinese "Lunar Calendar", because, when you go to the settings-> Notification & status bar, there is an option "Lockscreen Lunar Calendar" which you can enable and disable. When you enable it, the same chinese characters which are shown in the quick settings will be shown on the lock screen.

However, I would like to ask you if you can help me:

  • Which apktool or tool to compile / decompile the APKs are you using for modding Flyme roms? I tried to decompile and compile the Settings.apk, but all the times without success, there is still some "Failed resolving ResTable_map" error during compiling, and after pushing the modded apk to the device, the settings application won't start. I was reading somewhere on the net, that there is needed some special apktool designed for Xiaomi and some Flyme roms, but I didn't found it. And of course I tried with the different apktool.jar versions - 2.3.4 / 2.4.1 and so...)
  • Which Flyme framework apks are you using? I used only "flyme-res.apk" and "framework-res.apk" from the /system/framework folder in the device

Can you please let me know? Thanks. @boinare

3
  • I use BatchApkTool 3.7.3 by BurSoft (apktool.jar 2.4.1) and all directory "/system/framework", no special tool is needed. Thank you very much for the hint how to disable the "Lunar calendar"! But now I have unlocked the bootloader and switched to custom firmware MoKee ROM - it is a clean Android 10 - 100% translation, working notifications and much more! Flyme - bad OS, I do not recommend using it. MoKee firmware is also for your device: download.mokeedev.com/m1926.html To install it you can use my instruction: 4pda.ru/forum/…
    – boinare
    Feb 6 '20 at 22:40
  • Thank you for your response, I will try the tool which you suggested! I already tried EasyApkTool v 1.56 on Windows and jbart3h tool on Windows and Linux, but still I'm getting the errors during re-compilation of Settings.apk as I wrote (decompile is working). In the meantime I tried to decompile and re-compile the SystemUI.apk and it worked without any error, so I suspect there may be some frameworks / dependencies missing.
    – Spikadver
    Feb 7 '20 at 12:02
  • I've seen that there is a Mokee rom for our devices but I haven't try it yet - as I was afraid that there might be several bugs. I've seen that there are some headphone and Bluetooth issues, and therefore it was a "no go" for me. I'm pretty let's say OK with the above mentioned Flyme version (8.2.0.17 beta) but also there are some Bluetooth bugs / settings which I try to figure out. Will see, might give try to Mokee later :) @boinare
    – Spikadver
    Feb 7 '20 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.