2

I'm trying to just boot the TWRP image for my OnePlus 5t to then install a custom ROM. So I typed fastboot boot "C:\Users\Elias\Downloads\twrp-3.3.1-0-dumpling.img" and it seemed to work and I got the output:

Downloading 'boot.img'                             OKAY [  0.808s]
booting                                            OKAY [ 10.119s]
Finished. Total time: 10.992s

But the device just shows the text: "Fastboot Mode" and doesn't do anything. I now read on this forum that they somehow removed it but it would still be possible with: fastboot -c "lge.kcal=0|0|0|x" boot customrecovery.img but this flag doesn't seem to exist.

The output is:

C:\platform-tools\fastboot.exe: unknown option -- c

My goal is just to install a custom ROM without actually flashing anything except the ROM. So if somebody knows a different way, it would be welcome as well.

3

There are different versions of fastboot.exe available.

One old version I have has the command line option -c as

-c <cmdline>               override kernel commandline

The recent versions for Android SDK (v29.0.5-5949299) does not has the -c option. Instead it has the option --cmdline which seem to the the exactly same thing:

--cmdline CMDLINE          Override kernel command line.

Therefore you may succeed changing the command-line to

fastboot --cmdline "lge.kcal=0|0|0|x" boot customrecovery.img
7
  • the command works but sadly now I'm again just getting to the logo screen (the text saying fastboot mode), any idea? – Elias Nov 24 '19 at 12:49
  • @Elias Have you tried the older versions? Also have you read the XDA support thread on TWRP for the OnePlus 5T? forum.xda-developers.com/oneplus-5t/development/… – Robert Nov 24 '19 at 12:58
  • I've skipped through the thread and, correct me if I'm wrong, something about decrypting the data is not working? I'm now trying out a few older builds and see if I get one to work. Do you know if there is any log I could check? So I know what the problem actually is? Also, do you know what --cmdline "lge.kcal=0|0|0|x" does? maybe post a refference link? would be really nice of you :) – Elias Nov 24 '19 at 13:26
  • I have now tried the versions: 3.3.0-0, 3.2.3-1 and, the latest 3.3.1-0 which are all not working. – Elias Nov 24 '19 at 13:33
  • @Elias Using the kernel command line you can pass options to specific drivers. lge.kcal seems to be a part of the display driver system. Depending on the boot progress and the recovery it may be possible that you can get boot messages via adb. – Robert Nov 24 '19 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.