for the past few weeks my LG G5 has been unexpectedly restarting, apps have been crashing, and I've been getting messages like "Unfortunately Bluetooth has stopped" but for pretty much every app/service. Also, I've had the phone get stuck on boot loops which has made removing the battery the only solution to getting it to start again.

I've tried restarting the phone, resetting network connections, even doing a factory reset twice, none of which help. Even after the factory reset, before even putting in my Gmail account, I get a message "Google Play Services keeps crashing" and then "Google Duo keeps crashing", repeatedly to the point where I can't even do a internet search due to these messages popping up ever 1 second. If I do anything even a little memory intensive, the phone will restart which makes me wonder if it's a hardware issue with the memory.

I've had the phone for less than a year (It was a refurbished unit that was replaced under a third-party warranty I bought when I first about the phone from Costco). Otherwise the phone is in great condition. Not sure if it's just time to get a new phone. Any ideas?



If you did a fatory reset you should have already a data backup(or not), point is maybe doesn't matter if you try to flash a new stock rom, maybe the current one may be corrupt or something, otherwise consider the idea of getting a hardware issue.

  • Thanks for your reply. So the first time I restored the phone, I did a data backup. The second time, I started straight out the factory settings, without any data backup. In both cases, I still got the errors. Would this indicate a hardware issue, and if so is there anything that can be done to fix it?
    – James Dean
    Dec 1 '19 at 22:15
  • You should try to flash a new firmmware, just in case the one you have is broken, if were the case, you should go to some place where cualified personal will check your phone for hardware issues and try to fix it
    – Ariel
    Dec 2 '19 at 13:26
  • Thanks, so I tried re-flashing the firmware to Oreo 8.0.0 using LGUP tool. I'm not sure why, but after flashing and powering up the phone nothing had changed (same settings, apps, etc). I was expecting it to be returned to factory condition. Could this be because I had the same firmware before upgrading? I'm going to try installing a custom ROM to see if that helps. Will keep you updated. Thanks
    – James Dean
    Dec 8 '19 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.