0

Some apps even disable screen timeout completely (although it's still says 30 seconds on the settings menu)

How to stop that ?

Not to forbid globally, as there are some apps that I DO control the timeout via tasker. But only for that app

  • 1
    Do you keep battery saver enabled? That causes the screen timeout to default to 30 seconds no matter how many times you change it. – Firelord Dec 2 '19 at 15:03
  • 1
    I don't know yet if 3rd-party apps can change screen timeout without root access, but apps can indeed keep the screen awake. Not sure about the solution yet, but Android Developer documentation explains it further. Also, possibly related: How to modify possible values screen timeout on rooted devices?, including an answer that mentions per-app setting. – Andrew T. Dec 3 '19 at 2:35
  • Battery saver is off. The problem is apps telling the screen to stay ON, instead of obeying the system timeout. – Lucas BS Dec 3 '19 at 14:42
  • That solution you don't know yet is everything that we need :cry: Guess the third party app is the patch, then. PerApp is the recommended one from your links. Needs root only to control the CPU, says there. – Lucas BS Dec 3 '19 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.