0

Yet another occurrence of this when setting up a new phone, in this case a OnePlus 5 with the H2OS (Chinese) OS. I installed the current Oxygen OS official 9.0.9 from XDA, used the OnePlus transfer, and despite many strategies, could not get rid of this error. I tried:

Wiping the cache, other data in Google Play
Ditto other Google services
turned off WIFI, turned on, etc.
Reboot
Reinstalled Google play
Installed Google APK from APK store

I had seen these elsewhere working for some folks.

  • 3
    Welcome to StackExchange. So, you are trying to self-answer your post? The parts should be separated into distinct 'Q' & 'A' posts, however. Please see Help for the proper context of each. Possibly also the tour. – wbogacz Dec 4 '19 at 2:39
  • Welcome to Android Enthusiasts! On SE sites, it's perfectly fine to answer your own question (also see here) – but answers should be posted as answers, not as part of the question-post. Mind editing that out of your question, and move it to a separate answer? Thanks in advance! – Izzy Dec 4 '19 at 7:20
0

Finally the only thing that worked for me was doing a factory reset.
Hope one of these approaches works for others!
Having more potential solutions in your tool box increases your chances of success.

YMMV "Good luck, Jim!"

| improve this answer | |
0

I have come up against this problem today, and have found a solution when everything I found online failed to fix it.

The problem I had was that all Google apps weren't working. Chrome would not load pages, I could not add an account (hung on Checking Info and eventually gave the error " There was a Problem Communicating with Google Servers"), GMail app would load but would not show emails etc.

I found that the version of Chrome I had was a long way behind. I went into Setting/Apps and disabled Chrome. This basically re-enabled Android System Webview, and at this point I could then re-add an account, Gmail and the Play Store started working. I could then use Play Store to re-enable and then update Chrome, which then worked too. If you want to, you can then go into Developer Mode and set Chrome back as the Webview Implementation.

I hope this helps someone avoid spending the hours I did on this issue!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.