I'm trying to root a Vernee M5. I installed TWRP - which worked - and tried to use it to install Magisk - which didn't work (my guess is because of encryption?).

Now the phone always boots into recovery/TWRP and I want to install the factory ROM so I can try rooting it again.

However, using TWRP to install the ROM fails with the error:

Updating partition details...
Failed to mount '/data' (Invalid argument)

Rebooting the device opens TWRP again.

I tried Wipe -> Format Data -> yes, which also fails:

Updating partition details...
Failed to mount '/data' (Invalid argument)
Unable to mount storage

I also tried Wipe -> Advanced Wipe -> Data -> Repair or Change File System. Changing the file system fails with the above error message. Repair also results in an error:

/sbin/e2fsck -fp /dev/block/mmcblk0p48 process ended with ERROR: 8

Some additional info: TWRP is not asking for a password anymore when booting. Internal Storage is shown as 0mb on "install", but it does still contain a folder structure. The console also shows that full SELinux support is present & MTP is enabled.

How can I fix these errors and install the factory ROM?

  • 1
    May be a worn flash storage. How old is the device? Did you try formatting from CLI? Factory firmware flashing? – Irfan Latif Dec 6 '19 at 16:59
  • format data from terminal or adb shell – alecxs Dec 6 '19 at 17:02
  • @IrfanLatif Not that old. It was working fine before I started trying to root it. I'm trying to flash factory firmware, but that's not working (see question). – tim Dec 6 '19 at 17:11
  • @alecxs I can't boot into android, just recovery/twrp, so I think adb is out. I tried fastboot erase userdata, but that did not work (finishes with "OKAY", but same problems afterwards). – tim Dec 6 '19 at 17:12
  • 1
    @alecxs ah, format, not erase. fastboot format:ext4 userdata works (with a current version of fastboot). Still keeps booting into recovery after installing factory rom via twrp though. – tim Dec 6 '19 at 17:48

While formatting with twrp results in an error, formatting with fastboot worked for me:

  • start phone, which will boot into twrp
  • reboot -> bootloader
  • fastboot format:ext4 userdata. This will of course delete all data from the phone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.