1

So I wanted to root my OnePlus 6 after updating to android 10 (OnePlus6Oxygen_22_OTA_041_all_1911142043_dde113e5 3cd0f9.zip)

I tried booting into twrp via fastboot using fastboot flash boot twrp.img (twrp-3.3.1-x_blu_spark_v9.101_op6.img, my bootloader is unlocked).

I then tried rebooting directly into twrp, but now it's just stuck on the "Bootloader is unlocked" screen.

I can still boot into fastboot, but I can't boot into recovery or reboot normally since it just gets stuck on the bootloader unlocked screen.

Please Help!

Edit1: Changing my boot slot from b to a gives me access to the stock recovery. not sure where to go from here though.

Edit2: Fortunately, ManikandanGuru over at xda had uploaded the stock boot.img, which works perfectly.

  • the above fastboot command does flash twrp recovery permanently into boot partition, you can't reboot normally because boot.img is gone – alecxs Dec 8 '19 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.