0

Recently I switched from Lineage OS to Pixel Experience on my Xioami Mi 9t device. I made a backup of all my apps and data trough Titanium Backup and an update.zip file.

After flashing Pixel Experience and going through the setup I installed Titanium Backup on my phone and rebooted into TWRP to install the update.zip file. It flashed the zip file with no errors and automatically rebooted the phone into system.

However nothing happened and my apps and data were not restored. Then I wanted to restore them manually but trying to access my backup location on my external USB drive I found out I could not access my backup folder anymore, which was located at: /storage/extSdCard/Android/data/com.keramidas.TitaniumBackup

It is extremely frustrating knowing I have done everything to backup my apps and data but not being able to restore them anyway. If anyone knows a solution to this problem tell me, I would really appreciate your support.

  • 1. I created the zip file from batch actions. 2. The size is 1.3 GB. 3. I tried to open it from > settings > Storage and from solid file explorer. However I can't access the subdirectories anymore from Pixel Experience. Strangely enough I can access them from twrp recovery. 4. I tried that but I can't copy and paste them from usb to my computer using a file explorer. I think it's a matter of not having the right permissions. – Medeon Dec 26 '19 at 14:40
  • How does one change file permissions with Solid Explorer? Since I only have one usb port on my phone I can't 'adb push' from my usb-drive to my computer. – Medeon Dec 26 '19 at 16:01
  • Android folder is for apps, not for user. you have installed TB on another rom. the uid for folder does not match uid for TB anymore (because it's random given in order how apps was installed). android apps cannot access foreign uid's, thats why the "new" TP deletes "old" folder (and all it's files in it) read more – alecxs Dec 26 '19 at 20:23
  • As a matter of fact I can't access any folder anymore unless I open them from TWRP. I assume that the files are somehow encryted. I can copy/paste them from TWRP to my internal storage. – Medeon Dec 29 '19 at 18:13
  • try the sdcard Fix Permissions script – alecxs Dec 29 '19 at 19:35
2

Here is what worked for me. I booted into TWRP recovery. From there I copy pasted my backup files from my usb drive to internal memory. Then and only then I was able to access and restore my backups from Titanium Backup.

  • Sadly however, It also did not restore my apps, but one then it freezed and somehow magically removed all my backup files from the internal storage. :/ – Medeon Dec 26 '19 at 16:49
0

from Titanium Backup HOWTO:

  • install desired app (from Play Store or apk)
  • open the new app once
  • enable “System data migration” in preferences
  • Restore “data only”

(repeat this for each app)

  • i must say i never used TB and cannot test. but as long as you have the backup files on your PC, there is definitely a way to restore, no worry. as last option you can extract files manually and set new uid's – alecxs Dec 26 '19 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.