0

I was using Helium to transfer an app from an old phone to a new one, with the new one running Android 9. When the data is restoring, however, my phone just restarted with no apparent reason. I tried this multiple times with the same result. The process seems to be stuck at about 30MB, and would not go any further.

I have checked the backup file and it seems to be working, several backup files from Helium has the exact same size so I don't think that is the problem. Using adb restore command from pc on the .ab file doesn't help either, the screen is permanently stuck in the white restore screen, and when i terminate the process and check app properties i see the same 30MB in "user data", indicating the restore process stopped there as well.

Is there any way to fix this issue or, better yet, is there any way to backup and restore app data other than Helium? I know Helium is a thing of the past but I still don't want to root my new phone.

More info: new phone is Sony H4493 running Android 9, build number is 50.2.A.0.400

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.