0

I'm using WinSCP to FTP to my web service provider (I don't have SSH access). This works fine on Windows, and I wanted to see if I could also use an FTP client on Android so that I could manage files on my phone. I tried using Cx File Explorer, as I already had that installed.

I found that Cx File Explorer gave an error when connecting to my website. I tried another app, WebTools, and this also gave an error. WebTools included a log which showed that the app connected to my website correctly, but then it couldn't retrieve the file list.

My web service provider confirmed that they could connect to my website using Cx File Explorer, so it doesn't seem to be a problem with the app.

I also used the successful connection log from WinSCP, and replayed these in the terminal on Android using the Termux app. This also worked fine, but got stuck on the MLSD command, which suggests a problem with data transfer. I am using passive mode option in the apps.

It's a mystery to me why WinSCP works on my network, but the Android apps get stuck:

  • if it were a passive mode problem, then how come my web service provider was able to connect using the app
  • if it was a problem with my network blocking the data, then how come WinSCP

Does anyone have any suggestions how to resolve this?


Here is the terminal log from Android. My website is in a directory call 'unokay.com':

220 ::ffff:185.176.40.179 FTP server ready
user *********
331 Password required for ********
pass *********
230 User ******** logged in
syst
215 UNIX Type: L8
opts utf8 on
200 UTF8 set to on
pwd
257 "/" is the current directory
cwd /unokay.com/
250 CWD command successful
pwd
257 "/unokay.com" is the current directory
type a
200 Type set to a
pasv
227 Entering Passive Mode (185,176,40,179,192,213).
mlsd
^C
$

After MLSD command entered, the terminal hangs.

Here's a screenshot from Cx File Explorer - it may not be much help - but just so you know:

Screenshot from Cx File Explorer

0

Thank you to Irfan Latif for the suggestion to try MiXplorer. I just installed it and set up SFTP access, and it worked straight away.

As MiXplorer can also access local files and cloud storage, I will use this as my primary file explorer.

Thanks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.