2

I just discovered that when I tap the send button on WhatsApp the music stops for while. Actually it doesn't stop. The headsets goes silence for a second and then continues normally. The same thing happens when somebody sends a message to me. But, it doesn't happen when I receive messages while I'm on another screen. For example, at the very moment I'm writing this question and music plays on. I saw that I'm gathering new messages on notification area, but no problem occurs.

I'm using JBL TUNE 600BTNC Bluetooth headset. My phone is Realme 3 Pro.
Android version is 9.
The music players I tried are VLC and PowerAmp.

1
  • 1
    Have you enabled notification sounds for whatsapp?
    – Rahul Gopi
    Dec 29, 2019 at 16:26

2 Answers 2

2

you can try to change the settings Sound->Earphone mode->Notification ringtone in earphones to never. Downside: you won't get any notifications on your Headset anymore. I hope it helps.

Edit: This setting is available in OxygenOS if anyone else is facing this problem

6
  • 1
    I couldn't find related settings Dec 30, 2019 at 13:42
  • 1
    @ÇağlayanDÖKME but you are running Android 9 right?
    – knolperlap
    Jan 1, 2020 at 18:31
  • Can the Realme UI affect the settings screen? Maybe, it is disabling some of them. Jan 1, 2020 at 19:02
  • 1
    Oh that's right, on my Oneplus is running OxygenOS and the corresponding Settings UI, don't really know if it's possible to do this on a Realm device, but probably searching for this on the internet could help u find the solution to your problem
    – knolperlap
    Jan 2, 2020 at 15:28
  • 1
    your welcome, hope it helps a bit! ;)
    – knolperlap
    Jan 2, 2020 at 15:37
2

This worked for me

Go to your WhatsApp app > Settings > Notification > Conversation tones and turn conversation tones off. Your music will start working just fine even when you're sending messages.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .