0

I have a Moto G5 XT1676 with Android 7.0 stock firmware.

I rooted the phone with Magisk and installed TWRP but I never backed up my recovery.img partition. Now I want to flash a stock recovery partition so I can apply an ota update and in case I want to sell on the phone I want to be able to take twrp off and unroot. I don't want to flash an entire firmware.. Can someone help me in choosing the correct stock recovery.img for my phone?

Here are details of the firmware currently on my phone:

  • Baseband version: M8937_22.29.02.56.01R CEDRIC_EMEADSDS_CUST
  • Kernel Version: 3.18.31-perf-g4a0c859 Wed May 2 06:29:31 CDT 2018
  • Build Number: NPPS25.137-93-12
  • Blur Version: Blur_Version.25.321.18.cedric.retail.en.US RETGB

Here are the details of another stock firmware I downloaded.

  • SW Display Build ID: NPP25.137-93

  • SW Version: cedric-user 7.0 NPP25.137-93 12 release-keysM8937_22.29.02.56R

  • Build Date: Wed Nov 22 03:19:24 CST 2017

  • Blur Version: Blur_Version.25.281.12.cedric.retail.en.US

You see the two firmware are almost identical but I don't have enough experience to know if it would be safe to take the recovery.img out of the second one and use it in the first?

I tried booting into bootloader then..

# fastboot boot recovery.img

... to test the recovery .img file from another firmware but I got a picture of an Android lying down with red above him and his lid open and the words "No Command". I think that # fastboot boot is disabled on Android OS these days.

Any help much appreciated !!

Flex

3
  • I asked my question because I don't want to flash the recovery.img from a different firmware unless I know it is safe to do that. Do you know if it would be safe to flash the recovery.img from the second firmware I listed onto my phone? – FlexMcMurphy Dec 30 '19 at 13:53
  • you already "destroyed" recovery with twrp, so as long as recovery is a separate partition it is "safe" to flash "any" file (for testing). just check file size is fitting partition size. if it does not work, just flash twrp again – alecxs Dec 30 '19 at 14:50
  • 1
    I tried # fastboot boot recovery.img again and used the button combination from singhnsk and it booted into the stock recovery partition ok. Cheers. – FlexMcMurphy Dec 30 '19 at 20:20
2

The stock recovery booted perfectly fine. On Pixel, Moto , Nokia and several other devices, you will be presented with No Command screen. You need to follow the following combinations to proceed to recovery from there:

At no command screen:

  1. Press and hold Power key.
  2. Press and release Volume Up key.
  3. Release the power key.

You will be in the stock recovery. If that works, you can flash the image to your recovery partition.

3
  • Thanks for your help. Regarding the first sentence in your answer.. are you saying that you tested the recovery.img from the second firmware I listed above on a Moto G5 with the first firmware listed above and it worked? Or do you mean that you tested the recovery.img from the second listed firmware in some other phone and it worked or are you saying you just think it "should" work? Thank you. – FlexMcMurphy Dec 30 '19 at 13:58
  • 2
    @FlexMcMurphy Hi, I didn't test it myself. I only sourced your info and answered based on that. If you arrived at the No Command screen, that does mean that the recovery booted fine and can be used. Also, as much as I remember, the recovery image wasn't really modified with most of the OTA updates on those old phones. So, this build of stock recovery should allow you to install further OTA updates too. You can check it and confirm. – singhnsk Dec 30 '19 at 14:06
  • The difference between the two firmware I listed isn't that one is the other but with an OTA applied. My understanding is they are slightly different versions of Android OS 7.0 firmware for Moto G5 (Cedric). Thanks for the advice about the button combination to get past No Command. The recovery.img from the second firmware version worked in the first so I guess I will stick with that solution. Thank you. – FlexMcMurphy Dec 30 '19 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.