I am unable to uninstall any application on my Samsung Galaxy S. I have tried all possible ways (settings-applications-manage applications-uninstall and with the edit option). These applications are the normal ones downloaded from market.

But whenever I reboot my phone those applications are still there in my phone and its as if nothing has changed.

Also I keep getting this "settings.google.application has stopped unexpectedly" and am not able to open any of my apps.

I tried formatting my internal SD card by connecting it to the PC but that also didn't work.

  • 5
    Sounds like you may have to do a factory reset. Apr 19, 2012 at 17:45
  • Did you try to uninstall the apps with root permissions?
    – Flow
    Apr 27, 2012 at 6:45

1 Answer 1


(converted from a comment to an answer)

This might be a file-system problem.

I once got an overfull yaffs2 files system on /data to get frozen and wasn't able to delete/move/update anything. By executing 'dmesg' in a terminal or via adb you could clearly see it, was full of yaffs panic msgs.
Formatting was the only option (aka. factory reset).


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .