0

I recently tried to upgrade my phone (Lenovo P2a42, AEX 6.7, Android 9.0, rooted with Magisk 20.3) to Android 10 (HavocOS 3.1, Android 10). Unfortunately, it had quite a few issues and I ended up deciding to go back to Android 9.0. Unfortunately, that didn't go smoothly at all. Flashing the ROM works fine, but flashing OpenGapps causes a bootloop. I fortunately managed to use the aroma installer to get it to boot and be somewhat usable, flashing what I think is the bare minimum needed to have something stable, but it still leaves a mess.

Stuff keeps crashing in the background, and the SIM card is undetected, even after a reboot. Notable ones are the telephone service, download manager, and the media storage. I had to disable / uninstall quite a few packages via adb (on Linux) using pm uninstall -k --user 0 com.example.app to suppress the crash messages, otherwise they keep showing up and severely impede usage of the device. Additionally, TWRP refuses to flash OpenGapps, which I placed in my SD card, saying the zip file was corrupted, even though it was perfectly fine when viewed from my Linux system. Both my Linux system and phone have their storages formatted in ext4. I had to use adb sideload to get OpenGapps installed. Beyond that, as previously mentioned, I got the aroma installer to work. The reason for that, however, is because my usual setup with the aroma package resulted in a bootloop, and so did the super, nano, and pico package. I tried using the latest version of OpenGapps and also the older version, which was released around the same time as my ROM was. The version of OpenGapps doesn't seem to affect my success.

I would do a factory reset, but I would like to exhaust all other possible options first before that. Any advice would be appreciated.

Thank you for your time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.