0

I've been playing Battle Chasers: Nightwar on my phone for a few days now and to save battery I wanted to play it on my Macbook. However, after I install the game and launch it, I get a warning "Your device does not match the hardware requirements of this application". My phone is Galaxy S9 and my VM is also Galaxy S9. I've tried to increase video memory and enable 3D Acceleration but it doesn't work. Please help. Thanks, guys

  • Does the app start and then shows this dialog? In this case the app may have an built-in emulator detection, or some other capability of the virtual S9 is not as the app needs it. Most likely only the app author can answer you what and why this happens. – Robert Jan 16 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.