After purchasing a Motorola Moto G7, I rooted it using TWRP and Magisk. After a few months of having it rooted, I decided to undo the process in order to restore the ability to receive OTA updates. I flashed official firmware and re-locked the bootloader, but I still get the boot warning saying that a separate OS was loaded and that it's a security risk (yellow). After checking the system Settings, I discovered that I still couldn't receive updates either.

Relevant Information

I'm not sure if this makes any kind of a difference, but I did encounter an issue when locking the bootloader:

root@ThinkCentre-M900z:/home/user# fastboot oem lock
(bootloader) Flash valid Android images now
(bootloader) Then re-run this command to lock
OKAY [  0.003s]
finished. total time: 0.003s

After the above command failed to re-lock the device, I tried using fastboot flashing lock and that seemed to work.

root@ThinkCentre-M900z:/home/user# fastboot flashing lock
(bootloader) Phone is locked. Rebooting phone.
OKAY [  0.004s]
finished. total time: 0.004s

When I run fastboot oem lock after having used flashing lock, it gives a message stating that the bootloader is already locked.

I have two theories so far:

  1. The firmware I flashed is incorrect

  2. The bootloader is not actually locked (this seems improbable)

Is there any way to fix this? Or am I doomed to manually installing OTAs until I get a new phone? Please let me know if I left out any important information.

Any help is appreciated.

  • i guess the oem lock has kind of validation checks (which failed, for example wrong boot.img) but flashing lock does ignore this and lock the bootloader regardless the validation. you need to unlock again, flash the right files and lock with oem lock
    – alecxs
    Jan 21, 2020 at 22:41
  • @alecxs That's basically what it said when I ran fastboot oem lock. Any idea where I could get the "right files?" Jan 22, 2020 at 14:56
  • unfortunately no youtube.com/watch?v=OcuyyPMKX40
    – alecxs
    Jan 22, 2020 at 16:20


You must log in to answer this question.

Browse other questions tagged .