I backed up my Samsung Galaxy S2 on Kies before updating to Ice Cream Sandwich. After the upgrade I tried to restore, but the restore fails each time I try.

  • 2
    Does it provide you with any kind of specific error message when it fails? – eldarerathis Apr 20 '12 at 16:10
  • I am having the same problem, the error message is not detailed; it just says the restore failed. I have tried just selecting contacts rather than the full range of backed-up items but it has the same failure. Hoping there is a work-around before i resort to doing it all manually. – user14456 Apr 21 '12 at 8:00

I had the same problem; this is what worked for me:

  • from the phone clear the app cache (I used app2sd)
  • restart phone
  • restart computer
  • start Kies
  • connect phone to computer
  • run restore again


| improve this answer | |

Disable usb debugging in settings>applications>development and select samsung kies in settings>wireless and network>usb settings and try connecting the device again

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.