5

I recently upgraded to a Samsung Galaxy S9 with Android 9 Pie installed. It has an annoying feature, each time I e.g. get a message via Telegram, a pop-up window appears over any other application I am currently using on top of the screen:

screenshot of an annoying telegram popup notification on the BBC news app

I want to disable that for all apps. I found this reddit answer:

When you're in notification settings for an app, there's the label for the notification channel and the checkbox next to it. Checking the checkbox enables/disables notifications entirely. Tapping the label, as unintuitive as it is, brings you to the advanced settings where you can disable pop up/sound/vibrations.

If I go to e.g. Settings>Notifications>Telegram, I can tap each single chat and disable pop-ups. This is tedious, surely there is a global option to turn this invasive feature off?

3
  • On a regular Android device you can configure notification in Settings -> Apps and Notifications -> scoll down and disable notifications every listed app. But as you are on a Samsung device this may be a bit different as Samsung does not want it make it users that easy...
    – Robert
    Jan 28 '20 at 19:08
  • 1
  • @AndrewT. Thanks. So it seems in 5.0 you need an app do disable these notifications, and in 8.0 you need a command line tool but then the setting is gone once you restart the phone. In the words of AVGN, what were they thinking?
    – smcs
    Jan 29 '20 at 9:35
2

Yes there is!

  1. Set-up adb. Use THIS for reference
  2. Enter adb devices and make sure your device is there
  3. Enter adb shell settings put global heads_up_notifications_enabled 0 And you're done!

If you want to enable it again then just replace the command in step 3 with adb shell settings put global heads_up_notifications_enabled 1

Simple as that!

1
  • 1
    This is the best answer for disabling it for all apps. I don't want to go through the settings for all apps... Thanks! Oct 4 '21 at 20:45
1

My S9+ is running Androud 10 UI2 and Telegram 6.0.1
I had the same issue which I finally solved. I went all through the app settings, then i tried android-apps-telegram settings with no luck. I finally looked in android-settings-notifications and down at the bottom it says "looking for something else?" Click on the Smart pop-up view option and shut telegram off.

2
  • Awesome, they actually listened to the users apparently! For Android 9 I ended up solving it with the Android Debug Bridge as linked to in the comment by @Andrew T.
    – smcs
    Apr 6 '20 at 15:44
  • My S9 is running Android 10 by now and this does not work.
    – smcs
    Sep 8 '20 at 8:52
1

The in-app solution for Telegram 7.1.3 on Android 10:

Menu -> Settings -> Notifications and Sounds -> Private chats (or Groups or Channels) -> set Importance from Urgent to High

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.