I am having a little trouble with my Development Board it is Orange Pi 4B, running Android 8.1

Currently I have access to ADB root and also can modify the system folder or even place files inside the system folder but I want to grant Root Permission to my Application which the OS is not allowing. It also has SU placed in xbin folder but when I install SuperSu it says root undetected.

The commands that I try to gain root access to system were

adb root
adb disable-verity
adb reboot
adb root
adb remount

These all commands execute with success and I have access to modify the system folder but after trying everything I am still not able to grant SU access to my Application.

Even I tried to flash TWRP but the board is not entering Bootloader with the following command.

adb reboot bootloader
  • the shell starts running as Root. But i want to grant my app permission to have root access
    – Umer Kiani
    Jan 29, 2020 at 9:27
  • In terminal Emulator SU says Permission Denied. Using Terminal via USB Cable it turns into #.
    – Umer Kiani
    Jan 29, 2020 at 9:40
  • The issue is that supersu never pops up asking for permission. It grants permission to adb shell running via usb cable and denies all apps that are installed on the board.
    – Umer Kiani
    Jan 29, 2020 at 9:41
  • Let us continue this discussion in chat.
    – Umer Kiani
    Jan 29, 2020 at 9:42
  • 1
    Just to make it clear: even with the su binary the app(s) will not run with root permissions, they just have the possibility to execute other binaries with root permissions (just like you on a adb shell), but the app itself will still run with regular user permissions.
    – Robert
    Jan 29, 2020 at 15:42


You must log in to answer this question.

Browse other questions tagged .