6

I'm using a Sony Ericsson Xperia Arc S running Android 2.3.4 as a secondary phone. I used to surf internet until recently without so much hassle (using WiFi, not mobile data). But recently, some strange issue showed up.

I can Google search anything. But when I try to browse certain websites from search results, I get the error "Web page is not available". However, this happens when browsing only some of the websites, including Wikipedia (strangely, when I turn the Extreme mode in the Opera Mini I can browse the website).

I tried force stopping the browsers, cleared their data and cache, even did a reinstall of the two browsers, UC mini and Opera Mini. It is to be noted that I did root the phone sometime ago, but I was able to surf the web with this rooted device before this issue occurred.

The problem persists on other WiFi networks as well so this couldn't be an issue with my network. That said, other devices on the network works fine.

1
  • I had a similar effect (not on android, though) when I was in a network which only provided IPv6 access, not IPv4. Feb 11 '20 at 0:13
11

At the moment a large number of popular website are dropping support for all SSL/TLS versions below TLS1.2 because of the known vulnerabilities in TLS1.1/TLS1.0 and older.

Your device is very very old and does not support TLS1.2 therefore you can't connect to certain sites like https://wikipedia.org which requires TLS 1.2 according to the test of SSLLabs.

If you use extreme/compressing mode of Opera Mini you connect to a proxy at Opera instead that compresses and re-encrypts the traffic. Therefore using this redirection you can still access those sites as long as Opera not also increases the minimum TLS version on this proxy.

Some Webbrowsers may also include their own TLS implementation with TLS1.2 support. But usually they have dropped support for Android 2.x long time ago.

Conclusion: Your device finally comes to an end. If there is no newer custom ROM available (AFAIR for TLS1.2 Android 4.2/4.4 is required) allow it to rest in peace and get a new phone.

5
  • So does that mean, it would soon stop displaying even google.com ? (if google also implemented that in future)
    – user152435
    Feb 10 '20 at 18:28
  • 3
    @user152435 Earlier or later yes. For Google I don't know a concrete date but this site (Stackexchange) will drop TLS1.0/1.1 support on Feb 12th.
    – Robert
    Feb 10 '20 at 18:39
  • It looks like there were unofficial CyanogenMod/Lineage releases that could bring this device up to Android 7 Nougat. Performance would likely be awful and the device would still be exposed to a large number of known security vulnerabilities, so I would not recommend doing it.
    – josh3736
    Feb 11 '20 at 0:44
  • If anyone ever wondered why I'm against mandatory TLS, I'll point them to this post. (TLS is fine, there should just be an off switch somewhere). Maybe there's a way to make it work with a TLS 1.1 proxy server.
    – user253751
    Feb 11 '20 at 10:33
  • something similar happened to windows XP like last year - you had 2 chances - use the last working firefox ... or give up on the https-part of the web. Interesting was that google itself worked up to the point that you saw the google-doodle and search field - but when you used it - it couldnt deliver the results since those came from a different server
    – eagle275
    Feb 11 '20 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.