1

I have a Motorola G6 with Android 9 and a 32 GB mSD card (a good Sandisk one) formatted as internal storage and encrypted.

When I first used the card, I used the content migration utility to move some content onto the card and it worked fine.

Now I'm running out of space on the mSD card but I have some 10 gigs free in the phone.

So I tried to use the utility again in reverse: In Settings > Storage > Internal shared storage I tap the 3 dots > Migrate data. The screen says it will move about 4.5 gigs of stuff from the mSD into the phone.

I confirm, it shows a progress bar that jumps to 80% immediately and then I get the notification "Couldn't move content. Try moving content again".

It's been like this for weeks. I've tried rebooting many times, I've moved all the apps into the phone storage but whenever I download something, make a picture or whatever it's stored on the card and I can't affect it.

Any clue what's going on?

As a side note: say I'd want to upgrade the card to 64GB... How would I proceed, considering the current card is formatted as internal and encrypted?

Thanks

Edit: I realized a strange thing. The mSD card shows there's 13 gigs of apps even tho there are no apps on the card. There are 13 gigs of apps in the phone however. Methinks the system is confused about what is where.

  • you can try to move each app for it's own from settings – alecxs Feb 15 at 8:54
  • I've already moved all the apps manually. – KarlStack Feb 15 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.