I just bought a Google Pixel 3a phone, I cannot connect to xfinitywifi. I have no problem with many other Wi-Fi.

What happened is like this:

  1. When I tap xfinitywifi at the Wi-Fi list, I can see that it comes to the phase of acquiring an IP address.
  2. Then it shows I need to log in to the Wi-Fi.

At this point, I encountered several different problems:

  • I am led to a sign-in page, wifilogin.comcast.com, but before I can finish typing user name, I am led back to the Wi-Fi list interface and it shows either "not connected" or "connected but no internet"
  • I am led to that sign-in page, but before I even have a chance to type, it goes back to the Wi-Fi list interface
  • It does not leave from the Wi-Fi list interface at all. I can see some notification at the top saying login is needed, but it does not change to that login page

At the first start of the phone, it asked me whether I want to transfer everything from my old LG phone to this phone, I did that. The LG phone connected to xfinitywifi automatically.

I tried the following:

  • Open the browser and go to wifilogin.comcast.com, it only gives me a blank page
  • Click Forget the wifi and re-connect
  • Power down and on
  • Go to setting and delete all the user credentials.

None of these works.

Any suggestion?

  • Did you tried to connect in safe mode?
    – K S Maan
    Feb 16, 2020 at 7:04
  • As a work-around you could try force the login-page to appear by surfing to a HTTP only site such as http://neverssl.com.
    – Robert
    Feb 16, 2020 at 11:20
  • If you go to Settings - About phone - Android version, what security patch level are you on (this should be a date)? This was a known issue with the 3A and 3A XL with wifi networks that used a separate login page, until about the December security patch. You should be on "February 5, 2020" patch level.
    – acejavelin
    Feb 16, 2020 at 14:29

2 Answers 2


Using http://neverssl.com/ only works if you have a data connection. Maybe the problem is that Private DNS is enabled?


It is an obvious Pixel bug. I can't connect my Pixel 3XL to xfinitywifi hotspots either. I am totally gobsmacked that Google allows such bugs to exist in perpetuity. It is totally unbelievable that in some ways Google's stuff is trash and they don't care.

It should be noted that my provider is Google Fi. There own stuff does work together... Unbelievable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .