2

I am using OsmAnd+ 3.5.5 from F-Droid on my Samsung A3 2016 running LineageOS 16 (Android 9).

It all seems to working fine, but for whatever reason the voice navigation will not work, making me have to constantly look at the directions rather than listen.

What am I missing here? Is there a way of making it speak to me?

  • I think I have the same problem but on regular android with the free Osmand 3.5.5 from google play. Did you check if voice output works at all under (Android) Settings -> Accessibility -> Text-to-speech output or the LineageOS equivalent? – user2740 Feb 25 at 9:10
  • @user2740 I checked, the output works. Just to be double safe I changed the language from 'System Language' to 'English United Kingdom', and that still worked in settings. But it still didn't work under OsmAnd+ :/ – AdLinux Feb 25 at 20:30
1

I had the same problem (I think) with the play store Osmand 3.5.5 and android 8.1. Here's what I did:

  • wait for Osmand 3.6 to be released.
  • start a new route
  • go to options -> Navigation settings
  • tap on "voice prompts" even though it is already "on". Tap on the text not the switch!
  • You can see a bunch of options now such as "voice guidance" which maybe defaults to "Don't use". Make sure it is set to some language.
| improve this answer | |
  • It updated the 3.6.3 recently and what you suggested worked. Thank you :) – AdLinux Mar 14 at 6:44
1

PicoTTS (the integrated speech synthesis tool) has been removed from LineageOS 16 due to the lack of development.

I’ve looked for an alternative, but sadly couldn’t find anything on par with PicoTTS, so I eventually resorted to installing GoogleTTS, which I must say does a pretty good job.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.