1

I have unlocked the bootloader and enabled USB debugging. I can launch TWRP over fastboot and use the interface.

To root the phone, I tried the following:

  • Push the TWRP zip onto the device adb push ~/Downloads/SuperSU-v2.82-201705271822.zip /tmp
  • In the TWRP interface do: Install -> Add Zip -> /tmp/SuperSU-v2.82-201705271822.zip > Swipe to continue
  • Process finishes and Phone reboots
  • Open Root Checker Basic

"Sorry! Root access in not properly installed on this device. "

My goal is to be able to run su in adb shell.

What have I done wrong here?

2

1 Answer 1

1

SuperSU is discontinued and shouldn't work as expected on new versions of Android. You should consider using Magisk.

Flash the zip the same way you did for SuperSU. Then remember to launch magisk app and do the necessary additional installation steps.

1
  • I can confirm that Magisk worked for me
    – sdgfsdh
    Feb 21, 2020 at 10:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .