0

I'm sorry that this is almost certainly one of those "read the docs" questions, but I've been trying to do so for a while now, and my head is spinning. I suspect what I want is impossible, but would appreciate if someone can confirm/deny/point me in the right direction before I tear any more hair out.

I want to start to tinker with Android and determine whether I want to learn this environment or not. I have installed Android Studio on my Ubuntu Linux 18.04 primary development machine which has 32G RAM and an I7-4790 processor. However, I also have VirtualBox running and it's not an option to shut that down. Consequently, the emulator refuses to start.

My investigations then came across "genymotion", but their website seems to indicate that even a single dev license is over a hundred bucks a year. Am I right about this, or are they merely hiding a community edition somewhere? I'm not willing to pay for the tools at this stage of discovery.

So, my specific question: is there a zero money emulator that I can use on Linux, concurrently with VirtualBox?

EDIT: I took advantage of the need to do some upgrades and took VirtualBox down for ten minutes last night. I succeeded in proving that the emulator and the AndroingStudio installation work perfectly under these conditions.

  • I would update your question with which CPU your Ubuntu box is running and what happened when you tried to install an Android x86 flavor that supports VirtualBox. – Morrison Chang Feb 26 at 22:03
  • Added CPU type, but I don't know what you mean by "tried to install ..." I took what was offered by the AVD manager. It only appears to offer variations of Android hardware and Android OS revisions. This sounds like there's more for me to know, and that's exactly what I'm hoping to find out! :) – Toby Eggitt Feb 27 at 17:51
  • 1
    So you didn't find: android-x86.org/documentation/virtualbox.html and osdn.net/projects/android-x86/releases OR are you only looking for official sources in which case only HAXM is available. You might be able to run older ARM system images (Android 7 and lower) without HAXM but they run really slow (QEMU based). – Morrison Chang Feb 27 at 18:09
  • Didn't find anything other than Android Studio ;) I'm not snobbish about what I run as long as it's tolerably stable! So, I suspect that the x86 thing that I was just bumping into (comments I just made on Bo Lawson's answer) might be my path of least resistance. Thanks! – Toby Eggitt Feb 27 at 18:13
0

Yes, in fact Android absolu has an emulator called quemo There are a couple of beautiful things about quemo. For one you just need to use your Linux machine to Git clone it in. Second, it is from the Android Google source code and you do not need to download Android Studio.

| improve this answer | |
  • Interesting. When I poked around to find out what was going on when the emulator launched by Android Studio was failing, I found this command line in a ps output: Android/Sdk/emulator/qemu/linux-x86_64/qemu-system-6_64 -netdelay none -netspeed full -avd Nexus_6_API_27 But that's the emulator that was failing to run. Is this the one you're describing, or different (I notice you spelled "quemo", but the git repo, and this command are both spelled "qemu"). – Toby Eggitt Feb 27 at 17:59
  • Oh, and I added an edit. The emulator does work when VirtualBox is out of the picture. – Toby Eggitt Feb 27 at 18:03
  • Hmm, are you saying I should be running qemu as a VM inside VirtualBox? That seems to be what this post is driving towards: howtogeek.com/164570/how-to-install-android-in-virtualbox – Toby Eggitt Feb 27 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.