0

I am trying to install Lineage OS 16.0 on my Moto 4X. I unlocked the OEM bootloader. But when I enter the command 'fastboot reboot bootloader' it shows '< waiting for any device >'. There it stays until I break.

The next day it suddenly worked and I booted TWRP, install Lineage OS, G-Apps 9.0 micro and started the phone following the instructions at https://wiki.lineageos.org/devices/payton/install.

Lineage seem to work fine, but the G-Apps are nowhere to be found. I remember during the installation there was an error like 'can't access date/media., such a Directory does not exist' but it worked, or I thought that it did. I wanted to reinstall it all. Now I have the same problem again.

C:\adb>adb devices
List of devices attached
ZY224KGGGC      device

C:\adb>fastboot reboot bootloader
< waiting for any device >

USB debugging is enabled, the drivers on the PC are the newest from the Motorola website.

I used every USB port on my PC.

I tried my PC and two other laptops, all Windows 10.

Also I tried CMD, Powershell, and GIT-Bash for the commands. It’s always the same response. So I don't know what to do right now.

Does someone know where that problem came from?

1

You are mixing up adb and fastboot.

When a device is booted and visible via adb it can't be accessed via fastboot (and the other way around). Fastboot is only active while the bootloader is active.

Hence if your device is visible via adb devices you have to access it via adb.

If you want to switch to fastboot mode have to boot boot to bootloader mode by executing adb reboot bootloader.

Then you can use fastboot.

| improve this answer | |
  • thanks for the answer. – Haissem55 Feb 28 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.