I installed Lineage OS 16.0 on my Moto x4 using TWRP. I reboot and installed GApps. While installing there were no errors. But then after restart the Phone it stays in start sequence and after ca. 10 min it goes back to TWRP. When I only install Lineage OS it works fine, but without GApps. So I tried a few variations of combine these versions:

TWRP: twrp-3.3.1-0-payton, twrp-3.3.0-1-payton

Lineage OS: lineage-16.0-20200219-nightly-payton-signed, lineage-16.0-20200223-nightly-payton-signed

GApps: open_gapps-arm64-9.0-pico-2020019, open_gapps-arm64-9.0-pico-2020028, open_gapps-arm64-9.0-pico-20191017

Can you please help me? Did someone know what I am missing or doing wrong?


I found that I start in Slot A and installed Lineage there, but after reboot I am in Slot B but installing GApps works without shown error beside that main problem. When I go back to slot A and install GApps there it breaks with error code 64.

  • check if /system_root/system/build.prop is existing file, gapps fails to detect system-as-root when build.prop is symlink
    – alecxs
    Commented Feb 29, 2020 at 10:46
  • Any chance that you can capture logcat output during bootup process and add it to your post for diagnosis?
    – Yao
    Commented Aug 24, 2023 at 14:09

1 Answer 1


Whenever I used LineageOS 16 I had to use the "other" recommended GApps package by LineageOS.
The so called "MindTheGapps" package.

See here: https://wiki.lineageos.org/gapps.html

MindTheGapps link: http://downloads.codefi.re/jdcteam/javelinanddart/gapps
Mirror: http://downloads.codefi.re/jdcteam/javelinanddart/gapps

I realize they list OpenGApps there as well but for me, only MindTheGapps worked fine.
Ps.: LOS 17 never had this issue on the other hand. The phone I was using is a OnePlus 7 Pro.

  • Do MindTheGapps also have different packages (nano, pico, ...) like OpenGapps?
    – Haissem55
    Commented Feb 29, 2020 at 13:47
  • So I tried the link you gave me, but I have still the same problem.
    – Haissem55
    Commented Feb 29, 2020 at 13:48
  • And I couldn't find LOS 17 for the Moto X4
    – Haissem55
    Commented Feb 29, 2020 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .