Basically I am using biometric android device tab(photo attached) having android version kitkat(4.4.2) I have android app which is basically used for thumb verification. The app is working perfectly fine on wifi but when I am using data connection It's not able to access the service url. Then I tried to check the browser to verify that internet is working or not than I found that internet is also working fine on data connection then I tried different url's and found that the url's start http instead of https are not working on data connection but on wifi and all the urls having https are working fine and my service url which is being used by my app is also start with http that's why its not able to access the url. I tried a lot of solutions like:

  1. Resetting the android tab
  2. Clearing the browser cache and history (Although it has nothing to do with my app)

And one more thing all of the urls not matter http or https are working fine on wifi. Picture attached of my device and of the error I am getting while accessing the url start with http.

Also the same network SIM is allowing all types of URL's in other Android phones, so port 80 is definitely not blocked by MNO.

enter image description here


This site is temporarily in read only mode and not accepting new answers.

Browse other questions tagged .