1

I own a Klipad KL4888 tablet running Android 6.0.1

After a crash, I had to do a factory reset and a wipe cache from the recovery menu.

However, when restarting and running the setupWizard, it asks me a Wifi/GSM, but systematically the message "Can't connect to the internet" appears.

So I went through ADB (the device is unfortunately not pre-rooted), and in the logs I noticed this :

02-28 23:03:25.995 2784 2929 I SetupWizard.CheckConnectionTask: connecting to walled garden server. retries=0
02-28 23:03:26.246 970 1174 D WifiService: acquireWifiLockLockLocked: WifiLock{NlpWifiLock type=2 binder=android.os.BinderProxy@52836c}
02-28 23:03:28.123 970 1176 D WifiService: releaseWifiLockLocked: WifiLock{NlpWifiLock type=2 binder=android.os.BinderProxy@52836c}
02-28 23:03:36.239 2784 2929 W SetupWizard.CheckConnectionTask: IOException e=java.net.SocketTimeoutException: failed to connect to status.eqoe.cn/185.234.212.233 (port 80) after 10000ms
02-28 23:03:36.239 2784 2929 I SetupWizard.CheckConnectionTask: connecting to walled garden server. retries=1
02-28 23:03:46.301 2784 2929 W SetupWizard.CheckConnectionTask: IOException e=java.net.SocketTimeoutException: failed to connect to status.eqoe.cn/185.234.212.233 (port 80) after 10000ms
02-28 23:03:46.301 2784 2929 I SetupWizard.CheckConnectionTask: connecting to walled garden server. retries=2
02-28 23:03:56.360 2784 2929 W SetupWizard.CheckConnectionTask: IOException e=java.net.SocketTimeoutException: failed to connect to status.eqoe.cn/185.234.212.233 (port 80) after 10000ms
02-28 23:03:56.360 2784 2929 I SetupWizard.CheckConnectionTask: connecting to walled garden server. retries=3
02-28 23:04:06.421 2784 2929 W SetupWizard.CheckConnectionTask: IOException e=java.net.SocketTimeoutException: failed to connect to status.eqoe.cn/185.234.212.233 (port 80) after 10000ms

I also tried to disable Wifi, in order to be able to choose the "Ignore" option but obviously not enough rights.

The problem is that this famous site that is being tested is obviously no longer reachable. Is there any way to get out of this situation? An upgrade, but is the hardware compatible? Modify the Java sources, in order to ping another site?

Thank you !

3 Answers 3

2

I was stuck with the same device for 1 month. I finally got rid of this by DNS cheating.

  1. Setup your own DNS server

  2. Add a primary zone named status.eqoe.cn

  3. Add a ressource record A type on the zone with target 216.58.204.110 (IP found resolving clients1.google.com, setup android site)

  4. Declare your own server as DNS in your wifi setup

  5. Now setup your device and don’t forget to forget your wifi settings (in order to flush dns cache)

You will access standard google android setup, instead of unresponsive eqoe.cn one.

When your device is ready to work you can discard DNS setting on wifi setup

1
  • Oh, my God, you're a genius! Thanks a lot, the solution works perfectly (remember to leave the Wifi terminal to empty the DNS cache), and it works like a charm ! Too bad I can't give you any points yet, thank you very much !
    – Sigri44
    Commented May 3, 2020 at 7:54
1

I had this problem after factory resetting my Samsung Galaxy Tab 2 and trying to install a Marshmallow custom ROM (Slim6). The setup wizard successfully connected to wifi, but then hung at the 'Checking connection' stage, with no option to skip having to use wifi. The tablet doesn't have GSM, and there isn't any way of turning the wifi off before the setup wizard automatically starts.

I found a few potential solutions, hopefully at least one of which will be helpful to someone else:

  1. Rename SetupWizard.apk so that it never starts. Using the TWRP custom recovery, mount the System partition read-write, then from Advanced/File Manager, navigate to /system/priv-app/SetupWizard/ and delete or (safer) rename the .apk file.
  2. Edit the /system/build.props file to make the wifi part of the setup wizard optional. I didn't actually try this, but you can use Advanced/Terminal in TWRP to get a command line that will let you edit the file, and this gist suggests some ro.setupwizard keys that look like they would do the job.
  3. Try using a different GApps distribution, e.g. Open GApps or Delta GApps.

In my case, the first option worked, but it turned out that the real problem was that the version of GApps that I was using (Open GApps) wasn't compatible with my ROM; switching to Delta GApps fixed the problem with the setup wizard, as well as various other bugs.

Any of these options have the possibility of bricking your device if you get them wrong, hence I haven't described how to do them in detail. If you don't already know what TWRP or GApps are, or how to install them, then you need to do a lot more research first, until you are confident you understand the risks! Look for instructions that are specific to your model of device, and versions of the software that are known to work with it.

3
  • Thanks for posting your experience! I was working on the same Slim6 ROM on the same device (Tab 2) and hit the same issue. Reflashing with the Delta GApps solved the problem for me as well.
    – AdamsTips
    Commented Aug 19, 2021 at 18:28
  • Amazing, thanks for your feedback! Were you able to fully use your Galaxy Tab 2 without any slowdown ? I have the 7" version and I want to integrate it into my home automation system, the average Load Average of the OS being > 5 all the time, it is excessively slowed down whatever the use.
    – Sigri44
    Commented Aug 23, 2021 at 17:53
  • Yes. I have the 10" (GT-P5110) and had tried Slim7, which worked but suffered from lots of random lags, which made it annoying to use. Slim6 seems much faster, but I am not doing anything very intensive (mainly using it with the web interface for my home automation system too).
    – JRI
    Commented Aug 24, 2021 at 6:58
1

I had the "no internet" WiFi icon when the tablet came back from having the screen repaired. Internet worked, but automatic connections to WIFi didn't.

And then [recently] I started getting "open captive portal" messages

connect with adb shell:

adb shell

use superuser:

su

Check what setting is set (just out of curiosity): settings get global captive_portal_server

status.eqoe.cn

I didn't bother with any of the fallback or http/https settings, I just did the following setting:

settings put global captive_portal_server "connectivitycheck.gstatic.com"

and it worked! That's a relief!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .