3

Every time that I connect via USB my not-rooted Galaxy S6 (SM-G920F with stock Android 7.0) to my car (a Kia Soul 2015), this popup annoys me: "The connected device is unable to access data on this device. Reconnect the USB cable and try again. Android File Transfer or Samsung Smart Switch..." and I have to touch "OK" to dismiss it.

I dismissed it so many times that at this point I have nightmares at night about this popup that tries to kill me wrapping itself around me and taking my breath away.

What I tried is to set "USB configuration" to "Charge this phone". In this case the popup doesn't appear when I plug the USB cable, but after a while, if I also have enabled "USB debugging" (that I need), the "USB configuration" reverts to "MTP (Media Transfer Protocol)" by itself and the popup reappear at the next cable plug. Double annoyance!

Any way to kill that popup definitely?

(My car in this case: Kia Soul 2015)

2
  • Try the approach here if rooted
    – beeshyams
    Commented Mar 4, 2020 at 8:31
  • This behaviour is especially annoying when using your phone for maps. I enter my destination, start driving, and then the popup appears, completely covering the map and forcing me to adjust the window position and hit a tiny "OK" button while driving. In general the warnings on Android (at least my Galaxy S7) are insanely annoying (e.g. "warning, high brightness will drain your battery faster"... as if there is a single person who didn't know that; I don't need a reminder every single time). Would be great if there was an option to disable a warning permanently the first time it appears.
    – srcerer
    Commented Sep 24, 2021 at 16:20

2 Answers 2

4

I have been dealing with this all year and finally figured out a solution! Here's the steps:

  1. On your phone, go to settings.
  2. Scroll down to and click on "about phone"
  3. Click on "Software information"
  4. Find "Build number", and click on it until you get a message that says that you're a developer. I think it's 10 times.
  5. Go back
  6. Go back
  7. Scroll to the bottom and you should now see "developer options"
  8. Scroll down and click on "default usb configuration"
  9. Select "charging phone only"
  10. Go back DONE!enter image description here
3
  • Thanks, I've done this before in other contexts so am pretty sure it'd work! (My own problem went away some other way a few months back.) Welcome to StackExchange btw, thanks for contributing.
    – tog22
    Commented Nov 22, 2020 at 2:11
  • If I do this, will I still be able to transfer files to my phone when connected to my computer via USB, or do I need to switch it back before doing that?
    – srcerer
    Commented Sep 24, 2021 at 16:30
  • I have a bit different configuration/options but yes, it works, you have to switch to "charging only". I have an incomplete cable, it doesn't have the data wires and it is only good for charging, so I am always getting this annoying message. Only this work around helps
    – Nulik
    Commented Feb 14, 2022 at 0:48
0

I turned off USB Debugging and when I reconnect after that I don't see the popup anymore.

  1. Settings > Developer Options (you have to enable Developer Options)
  2. Developer Options > USB Debugging: Turn it off
  3. Click Back

Then, disconnect and reconnect and you shouldn't see the popup anymore.

Except.. I don't really like leaving USB Debugging off.

Fixing the data access problem instead may require rebooting the computer you connected your phone to, or installing a working driver (OS-specific), or other things like replacing your USB cable with a fully working one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .