1

Introduction

First of all I have quite old android box - Ferguson 3 TV. It's hardware based on platform very similar to MXQ/HD18Q with s805 processor. Stock rom based on Android 4.4 (not Android-TV). I was able to run LibreELEC Linux for this box in dual bot, or even from internal, so it is somehow compatible.

Now what happend...

I soft bricked it when trying to flash android custom rom from MXQ. The TWRP flashed just fine, and I flashed rom zip from this. After this procedure, neither system, not TWRP is not booting. After few tries I was able to flash LibrELEC to internal storage. I also booted Armbian (linux) from SD card. But recovery is still not bootable.

What I want to do

Is there any way to flash stock firmware from linux to unbrick the device? Or any other way? When I connect box to Windows PC, nothing happens, like Windows doesn't see it. So I think this booted linux is the only way I can modify the internal memory. I have stock firmware zip, from the Ferguson page. It is recovery zip, but contain inside boot.img and bootloader.img. The/system is just a folder. There are also /recovery folder which only contains some scripts to extract recovery from boot.

Any ideas how to save this box?

  • I tried Amylogic Burn Card Maker, but it doesn't boot. Linux does, but this utility doesn't. – Karls Mar 8 '20 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.