0

I brought a new phone recently (Blackview A60 Pro) and while calls and texts work fine, I can't access the internet. I spoke to my network provider (Talkmobile) who said that I need to add an APN.

However, for some reason, the option to add one is missing from my phone. There is no + sign and the 3 dots doesn't bring up an option to add an APN. The current APNs can't be edited as well. I've attached screenshots as well.

I downloaded myAPN but it didn't work on my phone and I'm not sure what else to do. Would really appreciate any help with this as I'm quite stuck and have tried everything.

. . .. .

5
  • Is the phone branded by Vodafone? May be this is some sort of "network lock" using the APN config? Or is this a company device, managed by an MDM? – Robert Mar 6 '20 at 13:13
  • Nope. it's supposed to be unlocked. I brought it from Amazon so it's not linked to any network or company. – Delwin Mar 6 '20 at 13:46
  • Are you sure the SIM card is in the correct slot. Dual SIM phones often only allow data traffic using the primary SIM. Additionally I would check if the device the device you bought was genuine. Compare the IMEI on the packing with the one displayed on the phone. May be someone bought the phone, replaced it with a branded one and sent it to back to Amazon. – Robert Mar 6 '20 at 13:52
  • Tried changing the sim slot and unfortunately it didn't do anything. Also checked the IMEI and it all matches up. Really not sure what else I could check. – Delwin Mar 6 '20 at 14:23
0

Have had the same problem. Thought it was the Blackview (A80 Pro) but when tried a different network's sim it worked perfectly. The APN's should get populated when the network is selected. In my case TalkMobile it did not populate the APN's. Put an EE sim in and it worked instantly. Have ordered a new sim so we shall see.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.