1

My playstore is not working from my device. Whenever trying to download or update, it just shows 'waiting for downalod' and that loading bar spins forever around the app logo. No i do not have any connection issues. My internet is strong enough, and to check, I have used other wifi and also cellular data. I have tried already clearing data, disabling and enabling, restarting, reset settings etc. Please help!

0

If you tried clearing the app data and restarting yet it's not working. Perhaps did you check 'App download preference' in the setting? Once I set it to 'Over Wi-Fi only'. And later even after changing it back to 'Over any network' it kept saying 'waiting for download'.

And if it's regional issue, try checking it with a VPN. But before trying it with VPN, force close Play Store and clear the data. 🧐

| improve this answer | |
  • well yes currently i managed to get it working with vpn. It is a regional issue. Hopefully they will fix it – iscream Mar 6 at 18:24
0

I had the exact same problem (which happened suddenly and without me changing anything) after a Google Libraries update. It persisted for some time and after a couple of Google Libraries updates it was fixed and now everything is updating normally.

I had tried to clear caches, reset Google Play etc. but nothing had worked. I suppose this is a bug in Google services.

| improve this answer | |
  • so, should I just wait for another update? Nothing is updating anyways – iscream Mar 6 at 14:50
  • When I am moving with my car, I usually put the phone in airplane mode. I had seen that if I had put the phone in airplane mode for quite a while (say half an hour) the problem stopped and I could update for some reason (I know it sounds crazy but it happened). And the problem started happening again after I turned off my phone at night and turned it on again in the morning. You could do that experiment. – papakias Mar 6 at 14:54
  • Google Libraries are automatically updated so maybe a future update will solve your problem. For me it took quite a while (2 months). In the meantime I did the workaround in my previous comment (which I accidentally discovered) – papakias Mar 6 at 14:55
  • yeah I'll try that thanks – iscream Mar 6 at 14:56
  • 1
    It seems to be a regional problem. Now, nobody from my country is being able to do the same. So I guess it will be fixed automatically in a while – iscream Mar 6 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.