0

I was trying to flash a Custom Recovery (TWRP) on my Friend's phone (Realme 3).

It was officialy supported by TWRP and was listed on their website so I downloaded the Custom Recovery. Then I unlocked the bootloader of his phone but yes a strange thing happened there:

After it asked for pressing the volume button to be pressed it unlocked the bootloader – but after that there was option "Select boot type". It had three options: Boot to Bootloader, Boot to recovery and last Normal boot. Further there was a arrow on the bootloader option. And there were some instructions something like volume up for select and volume down to move.

But I tried every button but the arrow was stuck on the bootloader option. So I connected it to my device and used the "fastboot reboot" command to restart the device. After restarting at the realme logo it was saying "You are unlocked you cannot be trusted". But after that it booted normally and the phone was Factory Reset.

After this in the Developer options the OEM unlocking was grayed out saying Bootloader is unlocked. Ok so we were successful in unlocking the bootloader.

After that I pasted the twrp img file in the platform tools directory and put the command adb reboot bootloader and after the device was in bootloader I used the command fastboot flash recovery name.img to flash the recovery. It said sending and then writing in my terminal.

After that I used the command fastboot reboot and the the key combinations (power+volume down) for the device which used to get into recovery for that phone – but this time, instead of going into recovery, it was in the bootloader.

So again I tried fastboot reboot command and this pressing the power+volume up but the phone booted normally. So this time I tried adb reboot recovery – but it booted into stock recovery. So again I tried flashing the recovery and tried using fastboot reboot recovery but it didn't work.

And yes I know that after flashing the custom recovery the phone should first boot into the recovery but as I said neither the key combinations nor the fastboot reboot recovery command so what can I do to prevent the system from overwriting?

  • 1
    Anway, after flashing TWRP, disconnect from laptop and then boot into recovery. This helped me with a similar problem with MiA1 – beeshyams Mar 7 at 9:33
  • The recovery is written as part of the boot process of the main system. To disable you have to modify the system image (not sure what exactly has to be changed on your phone). A common workaround is not to flash TWRP, instead when you need it just boot it via fastboot: fastboot boot <path to TWRP image>. In that case the flash is not changed but TWRP is directly loaded via USB and started without changing the flash. – Robert Mar 7 at 12:36
  • Ok @Robert and beeshyams I will try out both of them and let you know after reaching home... – Tanmay B Mar 7 at 13:56
  • it's curios that this TWRP is official but the xda support thread is closed. furthermore there are no instructions to solve this. at minimum you must disable dm-verity and delete/rename [system_root]/system/recovery-from-boot.p (if exist) This thread gives better support than the "official" forum.xda-developers.com/showthread.php?t=3944022 – alecxs Mar 8 at 10:55
0

Ok I was able to install the TWRP Recovery using my device's stock recovery's install method... And it worked!!!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.