I have a surnia xt1527 which was bricked because of some mistakes I made when trying to make a factory reset (I don't remember what I did because it was a while ago). The device has usb debugging disabled and hence I can't use adb tools. I also can't flash the stock firmware or a custom recovery from an sd card because the recovery won't let me access the sd card. Is there anything I can do to save the phone even though usb debugging is disabled? thanks

  • Have you tried this: Restore Moto E (2015) Stock Firmware
    – Robert
    Mar 10, 2020 at 16:44
  • @Robert yes and I get preflash validation failed error when I run flash partition gpt.bin Mar 10, 2020 at 16:50
  • GPT is the partition table. if validation fails you probably try to flash mismatching partition layout
    – alecxs
    Mar 11, 2020 at 6:07
  • @alecxs I get preflash validation failed almost everywhere, not only with gpt but also with the recovery, bootloader and the system.img_sparsechunk files also, I don't know why :( I'm trying to flash 6.0 which is the latest version so it's not a problem of downgrading Mar 11, 2020 at 17:45
  • fastboot flash works only when bootloader is unlocked (i don't know for mfastboot) you should try QPST
    – alecxs
    Mar 11, 2020 at 18:15


You must log in to answer this question.

Browse other questions tagged .