0

I've been trying to root my Lenovo Tablet for past few weeks and I've got no success.

I found out an article in XDA showing how to root it but when I tried I got stuck in the third step which was unlocking the bootloader.

When I typed fastboot oem unlock-go in my laptop and hit enter the adb and fastboot software just kept displaying "waiting for device" and nothing happened.

I have been searching whole internet to find a reliable tutorial because I am a newbie in this rooting thing.

Even One Click Root doesn't have any solution.

And I don't want to have any spywares in my device therefore I don't want to root it through any one click root services (like One click root, King Root, etc)

I apologize if I am missing something.

Any help would be highly appreciated.

Edit:— It seems like the OP of this post faced the same problem. Can anyone tell me how to use the sudo code?

I will try to install the drivers (as pointed out by an answer) and then edit here.

10
  • Does fastboot devices show device information? – beeshyams Mar 12 '20 at 14:01
  • It does show the device name when I enter fastboot and connect my tab. – Crocogator Mar 12 '20 at 14:04
  • Since you say are new to rooting, double checking - OEM unlock and USB debug in developer options done? – beeshyams Mar 12 '20 at 14:08
  • Yes, I did click on both of them. – Crocogator Mar 12 '20 at 14:09
  • 1
    I've finally unlocked my bootloader. I tried the sudo command and then usual fastboot oem unlock command and it worked. – Crocogator Mar 16 '20 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.