I have recently purchased the new HTC One S, and I am starting to get disappointed with Android and ICS. Multitasking only seems to exist for small apps like SMS, mail, and others. Every time I have a big game running - like Shadowgun, for example - and I press the home button or lock the screen, the game stops running. If I then go to the most recent apps and pick the game, it starts over from the beginning, it doesn't continue where I left it. I am used to a HTC HD2 with its old Windows Mobile, and I was always able to leave a game in its position and come back to it later, without any problems. Why isn't Android doing that for me? Is it a behavior only for ICS, or HTC, or is it the general behavior of any android mobile?

2 Answers 2


The general android behavior is to pause the application when you switch to some other app. It shouldn't cause data loss. In case the app is closed/killed by the OS while in background, it gives the app the option to save data in it's APIs.

If an app is using this proper/recommended way, then it can resume altogether without any data loss, i.e. you can start the game where you left it. But some games may have so much data that it can't be saved easily, that's why you are having issues with multi-tasking.

I haven't tried Shadowgun, so I can't comment on that, but in a game like Plants vs. Zombies it's properly implemented, and your game is properly paused and resumed. When you press Home on the device, it goes to a paused state automatically.

So in the end, it all comes down to App's own mechanics, not on HTC or Android.

  • It´s curious, I have tried again with shadowgun, and after going to home, I went back to the game and it continued from the last point, but after going home and back to the game again, it started from the check point instead of the last position.... Again, every time I go from the game to home, the Sense interface reloads. Commented Apr 24, 2012 at 10:30
  • It seems that your device may be running out of memory and the launcher itself is reloading because it was put into swap to free up RAM. The check point thing also shows that app is handling saving data sometimes. Perhaps you could first try killing all apps other than launcher via a Task Killer and the start the game and test the behavior. Commented Apr 24, 2012 at 10:37
  • Another game I have tried with is angry birds, and same thing happens, it doesn´t continue from the las state. Commented Apr 24, 2012 at 10:39
  • I have tried to run the game just after the mobile turned on, and the same happens. I also think that the problem is that it runs out of RAM and the SO unloads the launcher. I am afraid some update from HTC may be needed to solve this, I am afraid, anyway if you could try in your mobiles with some game like shadowgun, or even angry birds?. Commented Apr 24, 2012 at 11:07
  • I have an alpha build of CM9 (ICS Port) installed in my device and GPU drivers are not fully working yet, so can't play a game on my device for now. :| Commented Apr 24, 2012 at 11:23

I don't have this problem running on a SGSII on ICS. Have you tried pausing the game before leaving it? Also make sure you click the home button only once with a fast click.

Good luck.

  • First of all, thank you very much for your fast answers. I don´t have this behavior with all apps, only with big ones, that require a lot of ram, like shadowgun. Can you both try with one like it, maybe shadow guardian, nova, need for speed, or some like these?. Anyway, I had android froyo installed in the SD of my HTC HD2 running Windows Mobile, so I was able to load android from there, and as far as I remember, I didn´t have this behavior with games like these ones... Best regards and thank you very much. Commented Apr 24, 2012 at 10:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .