I have a strange issue. Just added some new folders in my Music folder after purchasing some new albums. Created them using Total Commander like always, transferred some mp3 files via ftp to the folders.

Now, some apps cannot find these folders or songs. It's not just my music app (Pulsar), I've tried re-installing without difference, and also tried a number of other music apps, some of them find the files and some don't. If I "open with..." the files using Total Commander the Pulsar app sees it and plays it without issue.

I have verified in terminal that chmod is the same as other and cannot see any other differences either.

Anyone have an idea of what the issue can be? Can it be related to different ways apps look for files or something?

I'm on a OP6, rooted with magisk but stock ROM.

  • I had a similar problem a couple of years ago & installed this app. It helped. I have no clue what the problem was and why this solved except a guess that SAF was broken and this fixed
    – beeshyams
    Mar 14, 2020 at 19:42
  • 1
    Tested stuff related to SAF, among others to setup to use legacy system with no change (appops set com.rhmsoft.pulsar android:legacy_storage allow).
    – Erik
    Mar 15, 2020 at 8:22
  • 1
    Did you try to force your Media Storage to refresh its index? In some instances, it doesn't do so on its own.
    – Grimoire
    Mar 15, 2020 at 9:32
  • 1
    Thanks Grimoire. Media Storage was the issue. Did a manual reset of it.
    – Erik
    Mar 15, 2020 at 10:28

1 Answer 1


The solution was that Media Storage didn't refresh. I manually cleared data in the Media Storage app and rebooted. After a while the app could find the files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .