0

Running Android 6.0.1 on Nexus 7 device, where I have disabled the following apps:

  • Google Play Movies and TV
  • Google Play Music
  • Google Play Newsstand
  • Google Play Books

Before disabling, I cleaned the cache and data.

However, the play store constantly sends me push notifications to update these apps, despite the fact they are disabled. How can I stop this?

I have also stopped all notifications from the Google Store app, this did not help either

  • Settings → Notifications → Updates is off

  • Settings → Notifications → Auto-Updates is off

  • Settings → Auto Update apps is off

And the worst thing is that you can't dismiss these notifications, so they stay all the time in the pull-down menu and push down the notifications I might care about.

UPDATE The tablet has Family Link installed and setup, which seems to be preventing enabling Developer options, hence cannot enable USB Debugging to attempt to delete the apps via adb.

  • I assume that the device is not rooted, in that case you could just delete those apps. Or install a custom ROM (junfortunately LineageOS has already dropped support for Nexus 7) without pre-installed Google apps and just install the OpenGApps mirco package. – Robert Mar 18 at 9:27
  • No, not tired rooted. I tried other roms in the past but performance slows down with such. – checho Mar 18 at 20:10
  • I haven't seen your deleted answer, but where do you think I should add that in the question? – checho Mar 23 at 18:34
3
+50

Have you tried resetting the Play Store?

It is possible (although very unlikely) that the Play Store has failed to detect that the apps have been disabled.

Go to Settings → Apps → Play Store → Storage → Tap the Clear data button.

Note: This will reset all your Play Store settings (update settings, notification settings etc.) to default. You might have to adjust these settings manually again.


If the above steps still don't solve your problem, try the below steps —

First, you'll need to enable USB debugging from the phone settings and download the Android debugging platform-tools package on your PC. The official documentation for this can be found here.

Then, connect your phone to your PC with a cable and make sure your phone is listed as device as given in the above documentation.

Uninstall the culprit apps for the primary user account

adb shell

This will bring up a command line shell prompt of your phone. Then enter the following commands —

pm uninstall --user 0 com.google.android.videos # Remove Play Movies
pm uninstall --user 0 com.google.android.music # Remove Play Music
pm uninstall --user 0 com.google.android.apps.magazines # Remove Play Newsstand
pm uninstall --user 0 com.google.android.apps.books # Remove Play Books
exit

The apps should not appear in your Play Store's apps list anymore.

EDIT - For Family Link managed devices (Based on OP's observations)

If the device is being managed by Google Family Link, then there is no way to access Developer Options on the managed device because Google Family Link makes advanced settings (like Developer Options, Install from unknown sources etc.) inaccessible on the managed device.
Also, as mentioned by OP in the comments below, if these settings are modified before enabling Family Link management, they are reset to their defaults as soon as management is enabled.

However, these advanced settings can be controlled by parents from the Family Link app for parents, and they can be accessed using the following steps —
Open the Family Link app for parents → Select your child → Look for your child's managed device → Tap Settings on the device card
Here, you should find controls for most of the settings which are not accessible from the managed device anymore. Look for the USB Debugging developer option and turn it on.

Then, by following the steps mentioned above to connect the managed device to a PC via ADB, you should be able to run the commands to get rid of the apps from the managed device.

| improve this answer | |
  • You might also try disable-user first, in place of uninstall, if that doesn't solve your problem, then try the uninstall commands. – ManSamVampire Mar 24 at 5:32
  • First proposal did not work. Will try tonight with the second one, as for some reason, USB is playing tricks on me - tapping the build number 7 times do no enable developer mode. Will dig deeper and get back. – checho Mar 24 at 6:35
  • 1
    @checo, using this or the ability to add multiple users in Android, can you add another user account, to the device, which is not managed by Family Link? This way you should be able to enable USB debugging for this new user account and, with the commands I provided, uninstall the culprit apps for the child account with the appropriate number for the --user option. – ManSamVampire Mar 27 at 8:39
  • 1
    @beeshyams I cannot disable the admin privileges for Family Link, as the option is grayed out and cannot be clicked, – checho Mar 28 at 8:38
  • 1
    @checho Glad to know it worked for you! I have edited my answer based on my understanding of your observations, feel free to edit it to add more details! – ManSamVampire Mar 28 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.