0

I have found that with my Pixel 4XL (or maybe it's Android 10) disabling Contacts syncing NO LONGER WORKS! With my older Pixel 2 it did work, and I would manually trigger a Contacts or Calendar sync when I wanted to. I have checked and double-checked all the settings (see below)... but it still syncs without me triggering a sync.

The settings I make are as follows ... Via Settings -> Accounts At the bottom of the main accounts page, there is a toggle named "Automatically sync data" with the text "Let apps sync data automatically". If this "Automatically sync data" toggle is ON and you then select your GMail account, and press the "Account sync" button, you are able to edit the(Google) apps you don't want to auto-sync (i.e. turn sync OFF). I do this (I switch all Google apps to off), and return to my GMail account page. I then see "Sync OFF for all items" in grey text under the "Account Sync" button (my upper case for OFF above). I then go back up to a higher level .. that is back to the main accounts page. The toggle "Automatically sync data" is still ON of course, and the grey text under it says "Let apps sync data automatically". I don't want this to happen, so I now set this "Automatically sync data" toggle to OFF. Here's the problem: after making this last change (i.e. "Automatically sync data" toggle to OFF), when I select my GMail account again, I now see "Sync ON for all items" in grey text under the "Account sync" button(my upper case for ON above)!! This is completely contradictory! How can it be that after first disabling auto-sync on all the Google apps and then switching off "Automatically sync data" Google signals "Sync on for all items" ?!?

And here's the bigger problem: the above message is correct. Because if I leave the settings as above the Contacts does indeed continue periodically auto-syncing. (I know this because if I delete my contacts in the Google Contacts app in the cloud after a short period all the contacts on my phone disappear too!).

I have tried removing my Google account and adding it again, but without success. It seems to me that this is either (a) a bug in the "Automatically sync data" implementation .. OR .. (b) a deliberate implementation of Google to fool people that their data is NOT being synced. I have also tried all sorts of variations and checked Google account settings in the cloud too (not much there!), all to no avail. It seems I cannot now disable auto-syncing of Contacts ... If somebody thinks I'm missing something help would be appreciated?

1
  • I am pretty sure this is just another Google scam .. because they don't want people to disable contact syncing. I posted this same message over on a Google support site, and after receiving a few feeble replies from a "Platinium" expert my post was disabled and labelled "This question is locked and replying has been disabled" . Here is that post: Disable contacts sync does not work I can confirm that everything I describe is still verifiable .. I test every week or so! Jun 3 '20 at 20:18
1

I've had the same issue and am happy that I'm not the only one.

Under Settings > Google > Account Services > Contacts sync you will find two Options - Automatically sync Google contacts and Back up & sync device contacts - to disable. I will test this the next few days and report back if it didn't do the trick. I guess they have moved this option and replaced it with a wired design.

1
  • I had these settings already unchecked on Android 10, but the contacts of unsynced accounts still show up. Oct 22 '20 at 7:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.