I have installed Android for PC from android-x86.org. The Android version is Pie. It is working fine, but videos are not being streamed. YouTube is working fine when opened in Chrome but no app is streaming the videos.

Android native libraries are also downloaded using settings. The OS is connected to VirtWiFi and LAN and even the YouTube ads also work in the YouTube app but only audio, no video.

Is there a different network route for Chrome and for apps? I can build a custom Android app also to troubleshoot the issue but not sure what to start from?

  • I would assume that there is a video codec problem if you don't get the video image. The codec support, especially the hardware based codec support is currently very limited. What GPU do you use? For questions on Android-x86 you should use Google Groups list: groups.google.com/forum/#!forum/android-x86
    – Robert
    Mar 31, 2020 at 11:33
  • Thanks for reply. If it is a codec issue then chrome should also not stream the videos. But videos are not working only in apps. Am I right? Looks like chrome and apps have different way of connecting to internet. Apr 1, 2020 at 5:15
  • 1
    Based on some commit messages it seems to me like Chrome has it's own codecs integrated and don't rely on the platform codecs.
    – Robert
    Apr 1, 2020 at 9:19
  • Oh.. any idea how to troubleshoot which codec is missing and from where to download them Apr 1, 2020 at 9:24
  • Android.x86 is working on the codecs hence I am sure there is not a simple way to just download and install a codec. Check the logs while the playback fails may be this unveils more details and allows you to open a bug ticket on the android.x86 project.
    – Robert
    Apr 1, 2020 at 9:27

2 Answers 2


I solved it by disabling the FFmpeg codec in the preferences.

Weird, but it fixed the issue when I was using an old HP Probook 4520s with integrated graphics.


I was using my old 1st gen i7 HP PC (and its iGPU).

What I have done in order to fix this is to install an old AMD card (because Nvidia cards aren't supported), and now it works.

EDIT: This was happening because the iGPU dodn't support HW video decoding, and so it failed and required the external AMD gpu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .