0

I am trying to use an USB-serial device that has USB-A connector via USB OTG. How do I "force USB host mode" so I can use USB-A to USB-C cable instead of using OTG adapter?

OTG works fine with other devices such as sd-card to type c adapter

Rooted Pixel 1 with Android 10

9
  • AFAIK for device with USB-C port there is no difference between an USB-A to USB-C cable to an OTG adapter. OTG adapters were necessary for Micro-USB ports. – Robert Apr 11 '20 at 12:55
  • I get no power just from USB-A to USB-C cable. isn't there physical resistor inside otg adapter so device can know the mode? – Phalelashvili Apr 11 '20 at 13:05
  • Usually the USB connection can be switched to "this device controls USB connection" (which means OTG mode). A lot of people are complaining about OTG problems with Pixel phones, not sure what the reason ist. What USB device do you want to connect to your phone? How much power does it require? – Robert Apr 11 '20 at 14:48
  • I think setting you mentioned isn't related. "usb controlled by this device" mode is enabled when connected to pc, if that's the OTG mode pc shouldn't be able to communicate since pc is ALWAYS the master. it's a regular serial device. requires 5v. I also powered it externally but still not detected as client device. OTG works fine with other devices such as sd-card to type c adapter – Phalelashvili Apr 11 '20 at 14:59
  • If it just does not works with this device then most likely the device type is not supported. I would try to connect the device to a Linux machine and check what driver(s) are used. Then check if the used Android kernel also contains this driver. In the end you may need a custom kernel(module) to make the device work. May be custom ROMs like LineageOS already has the correct drivers included. It may be worth a try. – Robert Apr 11 '20 at 15:04
0

To force your device into USB host mode, try connecting your USB-serial device via USB hub. Connecting a USB hub to your OTG adapter sets it automatically as host.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.