I am using Magisk 20.4 and trying to mount /system on a Google Pixel (1st gen) running Android 10.

I have tried using:

adb shell su -c mount -o rw,remount /system

that gives:

mount: '/system' not in /proc/mounts

The following also do not work:

adb shell su -c mount -o rw,remount /

'/dev/root' is read-only

adb shell su -c mount -o rw,remount /sbin/.magisk/mirror/system_root

'/sbin/.magisk/block/system_root' is read-only

I was also curious whether stuff in /sbin/.magisk/rootdir/system/ can actually override stuff in /system/ but that doesn't seem to be the case..

Has anyone managed to mount /system on Android 10? Is this issue specific to Google Pixel?

Cheers, Paschalis

Trying Hack5 suggestion gives me:

mount: '/system' not in /proc/mounts

Since I knew that /sbin/.magisk/mirror/system_root was a valid mount point, Ive tried the following, which still fails:

mount -wo remount /dev/block/bootdevice/by-name/system$(getprop
 ro.boot.slot_suffix)  /sbin/.magisk/block/system_root

mount: '/sbin/.magisk/block/system_root' not in /proc/mounts


Turns out it's impossible to mount /system on a factory image of Google Pixel. But, I was missing the whole point of Magisk! So I made a few modules and I can override/add the system libs and bins that I need. There is even support for apex on Android 10!

3 Answers 3


Your second command is correct, but the virtual block device is read only. IIRC, this is caused by the a/b mapping virtualisations.

Referring to https://android.stackexchange.com/a/158890/171244, you can see that specifying the correct block device will help. Try:

adb shell
su -c mount -wo remount /dev/block/bootdevice/by-name/system$(getprop ro.boot.slot_suffix) /system

This will switch from the virtual mapper (/dev/root) which is read-only, to the actual partition block device, making it writable

  • Thanks for the reply. Unfortunately it does not work (see my updated question).
    – Paschalis
    Commented Apr 11, 2020 at 18:31
  • sorry, i made a typo, the final /system should just be /
    – Hack5
    Commented Apr 11, 2020 at 18:34
  • I had also tested that and I haven't included on my edited answer. Still no luck :/ At this point I'm wondering even if it's possible!
    – Paschalis
    Commented Apr 11, 2020 at 18:38
  • It's definitely possible from TWRP
    – Hack5
    Commented Apr 11, 2020 at 21:42
  • 1
    I've never had a device with A/B so I'm stumped.
    – Hack5
    Commented Apr 13, 2020 at 9:22

ext4-dedup/logical partitions are ro by design


I think the problem is from Magisk.

I have a boot.img that I patched using Magisk 7.2.3. The latest 7.5.1 keeps giving me that error msg. Try using the old Magisk and you won't have that "mount: '/system' not in /proc/mounts" error.

  • you recommend to install magisk manager 7.2.3 right ? and I can see only 7.2.0 versions only..is that right you mentioned or it is 7.3.2 Magisk Manager version ? Commented May 28, 2020 at 3:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .