1

I've been using lineageOS 14.1 for a long time on my Galaxy S4 mini (gt-i9195) and recently wanted to try some apps requiring root access. In the developer options I could set root access only to "ADB only". I tried installing su from https://download.lineageos.org/extras via TWRP but the installation failed (probably because I tried installing the arm64 version instead of arm, I'm guessing retrospectively?). Anyway, I decided to upgrade TWRP to 3.3.1-0 (from 3.0.1-0 before I think) following random advice I found online. I started flashing 3.3.1-0 to the recovery partition via TWRP but it got stuck while "Patching system unconditionally". After more than an hour of this I powered off and restarted into recovery mode.

Surprisingly, TWRP now boots as version 3.3.1-0 without any issues. However, whenever I try to boot system into lineageOS I just get the Samsung startup logo and then the screen stays black.

Any idea how I might be able to start up lineageOS again? I would try rolling back to an older version of TWRP maybe, but I couldn't yet figure out how to get the image file onto the phone. I tried installing adb on my desktop and plugging the phone in via USB but adb devices does not find the phone. Might Odin work for this despite not having the standard ROM and without wiping the phone?

Unfortunately I don't have a backup, as I didn't have the storage space for it. But while there's nothing super important on the phone I would still of course prefer not having to wipe everything.

1
  • If your main LineageOS system partition does not boot I would try to re-flash that image instead of fiddling around with the recovery twrp (which should not affect the main OS).
    – Robert
    Apr 12 '20 at 15:08
1

Solved it without any data loss by putting a zip of the same LineageOS version I was using on a SD card and re-flashing with that from TWRP 3.3.1 (wiping only cache and Dalvik).

Thanks @Robert.

I still don't understand how exactly I screwed my system partition in the first place but I'm happy anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.